cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jvendetti
Level 2

Uninstaller does not uninstall one folder

I recently upgraded to InstallAnywhere Enterprise Edition (value pack 1). I tested the Uninstaller for my application and it successfully uninstalls everything except for one folder (and all of that folder's contents). I tried:

1). Checking the "Recursively delete all contents of this folder during uninstall" option for this folder, but this doesn't work.

2). Deleting and re-creating my Uninstaller action. This doesn't work.

3). I verified on the Install tab that all Product Features are selected to be uninstalled.

When I build the project, I do not see any errors in the build log.

Does anyone have any ideas for other things I can check? Or, has anyone else experienced this problem?

Thank you.
Labels (1)
0 Kudos
2 Replies
pv7721
Level 20

Can you reproduce your issue with a smaller installer (say for instance remove all other folders, and just keep the single folder that won't uninstall: does this still happen?
0 Kudos
jvendetti
Level 2

I removed all subfolders from the single folder that won't uninstall and the problem is no longer reproducible. (The subfolders are all "Install SpeedFolder" actions).

Is there any other advice on how to debug this problem?

pv7721 wrote:
Can you reproduce your issue with a smaller installer (say for instance remove all other folders, and just keep the single folder that won't uninstall: does this still happen?
0 Kudos