Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 5

Silent installer produces file with errors in directory install is launched from

I have an installer, that when run in gui or console mode, works fine.
We have a bunch of customer installer people and QA who want to use the silent installer.
When they do it produces an error file called "custom" in the directory the installer was launched from.
What is producing this file? The installer runs to completion and says it's ok, but users say some artifacts are not right.
The installer runs custom code to accomplish most of what it does. Just guessing the title of the file produced, "custom", might have to do with that. Any ideas would be appreciated.

Here is the contents of the file:
en_needMoreSpace=WARNING! The amount of $INSTBASE disk space required to perform this installation is greater than what is available. Please free up at least $free_up kilobytes in $INSTBASE and attempt this installation again.
en_vmDownloadError=Error in downloading the VM. Installer exiting...
en_launch=Launching installer...
en_jreExtractFailed=The included VM could not be extracted.
en_invalidUnzip=Invalid unzip command found
en_checksumPassed=MD5 checksum verification for downloaded JVM passed
en_corruptedFiles=The size of the extracted files to be installed are corrupted.
en_tmpCleanup=WARNING! This installation has been interrupted. The installation process will now terminate and the temporary files it is using will be deleted from $ZIPLOC.
en_downloadLoc2=Download location=$jreDownloadFileName_1
en_downloadLoc1=Download location=$jreDownloadFileName
en_downloadedVM2=Downloaded VM Pack using URL=$jvmSpecBuildWithoutVmDirectDownloadUrl
en_downloadedVM1=Downloaded VM Pack using URL=$jvmSpecBuildWithoutVMNotFoundDownloadUrl
en_noEnoughSpace=WARNING: $INSTBASE does not have enough disk space! Attempting to use $HOME for install base and tmp dir.
en_extractJRE=Extracting the JRE from the installer archive...
en_jreUnzipFailed=The included VM could not be uncompressed (GZIP/UNCOMPRESS).
en_unpackJRE=Unpacking the JRE...
en_spaceUndetermined=WARNING! The amount of $INSTBASE disk space required and/or available could not be determined. The installation will attempted anyway.
en_jreUntarFailed=The included VM could not be unarchived (TAR).
en_reDownload=Please try to download the installer again and make sure that you download using 'binary' mode. Please do not attempt to install this currently downloaded copy.
en_configure=Configuring the installer for this system's environment...
en_prepareInstall=Preparing to install
en_checksumFailed=Error!! MD5 checksum verification for downloaded JVM failed. Installer exiting...
en_extractRes=Extracting the installation resources from the installer archive...
en_defaultCase=default case
en_noPermission=The temporary install directory: $INSTBASE does not exist or you do not have permission to write to it.
en_iatempdirNotPresent=You have used the IATEMPDIR to set the install base and tmp dir for this installation. However, the directory $INSTBASE does not exist or is not a directory. Please choose a valid directory.
Labels (1)
0 Kudos
(2) Replies
Level 9

From 2017 SP1 release notes:
When performing a silent installation in Linux machine, no custom files are being left behind. Previously, a file with the name ‘custom’ was being created in the installer launch directory when performing a silent installation in Linux machine
0 Kudos
Level 2

I noticed this error after terminating the silent installer before it finished. I also saw the "custom" file, tried deleting and adding a new one, tried deleting my installer and copying in it again, and tried restarting my machine but none of this has fixed the problem. Any suggestions??

0 Kudos