tarun91
Level 4

Linux installer without command prompt

Hi,

I am creating one installer for linux using InstallAnywhere 2010. I am using Redhat. I created the installer, installed it. When i click on Desktop Shortcut created upon installation, command Prompt (terminal) opens. Application is working fine. But, I don't want to terminal window to open when i run this application. As soon as, i close terminal window, application stops.

What i want is:

Upon running the application, terminal window shouldn't open. (I tried javaw instead of java, but it closes terminal as soon as it opens, so application stops automatically)

How should i do it?
Labels (1)
0 Kudos
3 Replies
jerome_IA
Level 9

Hi,

You should replace installanywhere shortcuts in your installation and create .desktop files instead.

The file name "$USER_SHORTCUTS$$/$YOUR_APP.desktop" should look like this:

[Desktop Entry]
Type=Application
Name=APP_NAME
Exec=$USER_INSTALL_DIR$$/$EXECUTABLE_NAME
Icon=$USER_INSTALL_DIR$$/$ICON_NAME
Terminal=false

--Jerome
0 Kudos
tarun91
Level 4

Thanks for the reply. Actually, i don't want to do it manually. After the installation is over and i click on desktop shortcut generated by installer, application should run but no terminal (command prompt) should appear. How should i do it?
0 Kudos
jerome_IA
Level 9

tarun91 wrote:
Thanks for the reply. Actually, i don't want to do it manually. After the installation is over and i click on desktop shortcut generated by installer, application should run but no terminal (command prompt) should appear. How should i do it?


There is no manual operation to perform!?

Replace your unix shortcut in you installer (UI - install tab) like explain above, just replace the paths and names to match you specific install settings.

By setting 'Terminal=false' then there will be no terminal.
0 Kudos