jpitz31
Level 2

InstallAnywhere 2012

I am aware of the JVM settings under the Project topic. But if the desired JRE is not found, installing the bundled JRE is not desired for my situation.

The JRE packaged is from IBM and is very old. Is there a way to check for a version of the JRE and present the user with a dialog indicating that the user should exist the install and install a newer version of the JRE.

Thanks

Joe
Labels (1)
0 Kudos
1 Reply
RamyaVenkatesh
Level 7

Hi Joe,

You can have a 'Compare InstallAnywhere variables numerically' rule under Project > Rules to check the java version before the installer launches. This could be something like - Compare $prop.java.version$ >= 1.6 e.g.,

You can customize the message to display when the rule fails.

Let me know if this helps. Thanks.

jpitz31 wrote:
I am aware of the JVM settings under the Project topic. But if the desired JRE is not found, installing the bundled JRE is not desired for my situation.

The JRE packaged is from IBM and is very old. Is there a way to check for a version of the JRE and present the user with a dialog indicating that the user should exist the install and install a newer version of the JRE.

Thanks

Joe
0 Kudos