srik_008
Level 7

Install always Installing as Upgrade action

Hi all,

I have an installer to install our application
we will install our application using two action
1.First Install
2.upgrade

when use first install the installer will installs the application files in one folder C:\application and configuration files in one folder like C:\Configuration

when we use upgrade action the installer will keeps the configuration files as it is C:\Configuration and deletes the application files and replaces the new files in C:\application folder

I have used 1.First Install to install our application and after some time I have to upgrade the latest installer but by mistake again i have used First install without uninstalling the previous installer.

here i have a problem after this when i am trying to install as first Install it always installing as a upgrade action.Because of this the installer is unable to install configuration files in C:\Configuration folder.

i have deleted all temp files and folder created by installer but still iam facing the same problem. I cant find the where the data is stored in machine to behave like this.

can anyone help me .How to solve the problem.

Regards
Sree
Labels (1)
0 Kudos
4 Replies
RamyaVenkatesh
Level 7

Try uninstalling the product first, then re-install and upgrade.
0 Kudos
srik_008
Level 7

RamyaVenkatesh wrote:
Try uninstalling the product first, then re-install and upgrade.


I did as you explained but still facing the problem. Can you tell me where the data is stored and why it is behavind like this.

Regards,
Sree
0 Kudos
RamyaVenkatesh
Level 7

You cannot delete any data manually.

So, you installed the application twice successfully. However, for the third and subsequent times its always going to the upgrade option? That's unusual. If you can install it twice, you should be able to install a third time. Please share your project file, we will have a look at it.

Thanks
0 Kudos
srik_008
Level 7

Hi Ramya,

Thank you for your reply. I got the solution for this. One file is stucked inside the folder C:\Program Files\Zero G Registry\.com.zerog.Registery. I have deleted the file then i can able to do the fresh install.

Regards,
Sreekanth
0 Kudos