Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 2

IA5.5 Uninstaller not working with JRE 1.6


Im using InstallAnywhere 5.5 to build my iap_xml and bundling 1.6 vms with the installer and uninstaller.
The installer works fine but when I run the Uninstaller I get the following internal Invocation Target Exception:
java.lang.UnsatisfiedLinkError: com.zerog.ia.platform.Sys.getSpecialFolderJNI(I)Ljava/lang/String

Stack Trace:

java.lang.UnsatisfiedLinkError: com.zerog.ia.platform.Sys.getSpecialFolderJNI(I)
at com.zerog.ia.platform.Sys.getSpecialFolderJNI(Native Method)
at com.zerog.ia.platform.Sys.getSpecialFolder(DashoA8113)
at ZeroGau.a(DashoA8113)
at com.zerog.ia.installer.util.magicfolders.AbstractWin32MF.b(DashoA8113
at com.zerog.ia.installer.util.magicfolders.MagicFolder.initializeAllMag
at com.zerog.ia.installer.Main.c(DashoA8113)
at com.zerog.ia.installer.Main.d(DashoA8113)
at com.zerog.ia.installer.Main.a(DashoA8113)
at com.zerog.ia.installer.Main.main(DashoA8113)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.zerog.lax.LAX.launch(DashoA8113)
at com.zerog.lax.LAX.main(DashoA8113)
Invocation of this Java Application has caused an InvocationTargetException. Thi
s application will now exit. (LAX)

Strangely, the uninstaller works if I modify the uninstaller.lax file and reference it to a 1.5 jre. The issue is that my custom code which runs in the installer is compiled in 1.6 and the uninstaller fails with a badclass version error if I try this workaround.

Is there a compatibility issue with the installer/uninstaller using jre 1.6 or is there any workaround for this?

Im badly in need of a solution here. Any suggestions would be greatly appreciated.

Thanks in Advance.
Labels (1)
0 Kudos
(5) Replies
Level 20

IA 5.5 is a too old version, AFAIK it doesn't even support Java 1.5 (the support for this has been added in IA 8!) so obviously it won't support Java 1.6.
0 Kudos
Level 2

Thanks for your input. But the strange thing is that the installer seems to work for me. If it doesnt support 1.6 then the installer shouldnt work either. Anyhow I would try to build my project file using IA8 and see if it would work.
0 Kudos
Level 5

Was this issue resolved? I am getting the same error on executing my unisntaller on windows.
Built using IA 2010 with vms JRE 1.6
0 Kudos
Level 20

If you're using IA 2010 you should post your issue to the relevant forum. Thanks!
0 Kudos
Level 2

I am having the same problem tracking rankings using SEOe in Google that we are having with MSN.

Sometimes it works and other times it says not found even though they are.

Is anyone else having this problem?

0 Kudos