Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 6

How works InstallAnywhere Ant Task with Bundled VMs?


I'm trying to use the ANT Task to build my project on a build machine.
I would like to use bundled VMs.
I want to use bundled VMs that I download from my config management server.
I want to keep empty the /resource/installer_vms directory.

I tried to set in the buildinstaller task:


but I got this:
[buildinstaller] Building Linux (VM) web installer...
[buildinstaller] Adding other errors: Unable to retrieve VM pack executable path from: SunJRE160_12LinuxINTEL.vm
[buildinstaller] Build failure: Error Generating the Linux with VM Installer.
[buildinstaller] Path to executable in VM Pack is missing

I also tried to put only the path to the folder when is the bundled VM as the name path would suggest. But I got the same result.

Interestingly, once I put the VM in the /resource/installer_vms.
it works but only if the path is the path that contains the vm name.
So what is the use of this parameter if it cannot be used?

Also I tried to use the configuration element I got the same issues and besides as I have a platform with too different VMs, I'm not able to set as in the iap_xml file the output folder. It creates for instance Linux and Linux_1

Document is very poor as usual. 😞

Could someone help me on this?


Labels (1)
0 Kudos
(2) Replies
Level 3

Same issue but for Windows VM pack. And I've read many similar complaints. Does this parameter to the build task actually work or not (seems that it doesn't)?

The documentation for the buildinstaller ant task is...cursory at best...

In fact, the documentation for the entire product is kind of a joke.
0 Kudos
Level 3

I had the same issues as you guys. I eventually just put the vms in a location where I had the diskspace to keep them and put soft links to the vms in the installer_vm directory.
This is what I used:



This allowed me to loop through the platforms and use any platform I wanted, with any vm I wanted, as long as soft links or the vm was present in the projects directory or the installer_vm directory. Again I realize this isn't what you want, but it works.
0 Kudos