Pravita
Level 2

How to Configure for service to be started

Hi!

I am trying to install a software as service. But for some reason it fails.
According to the windows "Event properties":
Error 1920 Service failed to start. Verify that you have sufficient privileges to start system services.

This is how I have configurer when it doesn't work:
in the "Organization | Components" I open the file object that I want to have as an service.
In this case Mysqld-nt (I am doing a special installation for MySQL for my corporation).
I choose "Advanced Settings" and then right click on Services and choose
"new service".

Here is my settings:
Enable Service Install: Yes
ServiceType: win32 that runs in its own process
Interact with Desktop: No
Start type: Automatic
Abort install on failure: No

Control settings:
operation time [Install Start]
Install Start : Yes
Install Stop (and the rest): No
Wait Type: Wait for the event to complete
Arguments:

This is how I manage to get it started, but fails when I try to uninstall the software:
Behavior and Logic | Custom Actions And Sequence:
I right click on Custom Actions.
There I create an custom actions
On Action Type:
Type=Launch an executable:
Location= Installed with the product (I have created a bat file that I then converted to an exe file with i c:\%System%\system32\iexpresse.exe)
Action Parameters:
Source: Link to the file:
Target: (Blank, since the above converted scriptfile is selfcontained)
Additional Options:
Return Processing: Synchronous (Ignores exit code)
Respond Options:
In-script Execution: Deferred Executiom
Insert into Sequence:
Install execute Sequence: After Movefiles

Even thou the last "technique" work to install and start up the service.
I can not uninstall the installation.
With the first technique. I can uninstall the installation.
But I can not start the service, and the installation fails.

So I wonder if there is someone out there that can help me how to configure
InstallShield 2010. This is my first time I am doing this, and would appreciate any help that result in an succesful installation.

Sincerely
Pravita
Labels (1)
0 Kudos
1 Reply
lkhoney2003
Level 6

Pravita,

I think you are using InstallShield tool for packaging.
If yes then you have posted your question on wrong fourm. Please choose right fourm.
0 Kudos