cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
SeanDav
Level 3

Download File Failing

I've got a step in my install anywhere 2011 SP3 package to download a merge module if it fails to find it on the system. Everything works fine except for the download step. I've confirmed that I'm able to get to the URL and download the file from the computer I'm installing it on. But I keep getting this message in the install log
Hostname specified in the URL is incorrect.

The data in the log looks fine:
Error occurred while installing the following Action, hence rolling back the installation....!


Action Name: Download File Action
Action Description: Download File Action : URL: http://www.ourfakecompany.com/files/MergeModule.iam.zip
(I changed the URL from our company one, it's not actually that)

I've got it marked with the HTTP option in the install script, and port 80 and the size set. Is there something obvious I'm doing wrong? Nothing jumped out at me in the documentation.
Labels (1)
0 Kudos
3 Replies
SeanDav
Level 3

I've tried some more testing, and it doesn't seem like I can get any URL to work. I've tried various combinations of FTP and HTTP sites, and even just trying to do a simple download of an image gives me the same error. I've uploaded a screenshot of what I've tried in the installer. I've tried setting the size value to a value larger than the actual size, 0, and the actual size of the file. Any ideas?
0 Kudos
RamyaVenkatesh
Level 7

Hi,

I tried using the download file action to download vm packs from the flexera website and it worked fine. Does the url you're using reguire any login? If so, the action will fail. Can you give the other links you tried with this action? We will be able to help better.
0 Kudos
shivar12
Level 2

we are facing this issue recently, it was working fine earlier. but not sure what happen in the network side. its able to download the link mentioned below manually in the browser

  Is there a way to find the exact reason for it.

Action Name: Download File Action
Action Description: Download File Action : URL: "http://download.microsoft.com/download/5/B/C/5BC5DBB3-652D-4DCE-B14A-475AB85EEF6E/vcredist_x86.exe"

 


Error Details as below:

 


Connection with the specified server could not be established during Download File Action. Please check your firewall settings or URL and/or port number specified.

0 Kudos