cancel
Showing results for 
Search instead for 
Did you mean: 

Flexnet licensing Service on reboot doesn't work in RHEL 7 + SUSE 12 SP4 and above

Flexnet licensing Service on reboot doesn't work in RHEL 7 + SUSE 12 SP4 and above

Symptoms:

It had been noted that due to some OS dependencies, post a reboot the FNLS (Flexnet Licensing Service) is unable to start automatically and which leads to a failure of multiple kinds on virtualization platform based licensing.

Diagnosis:

/var/run/FNP directory is getting deleted after restarting the machine and FNPLicensingService is not able to create the /var/run/FNP/FNPLicensingService64.pid file.

Solution:

Following is the work around script. (Kindly put your native paths of toolkit directory)

[Unit]
Description=This Service re-install's FNPLicensingService on Boot
After=network.target remote-fs.target

[Service]
Type=forking
RemainAfterExit=yes
User=root
WorkingDirectory=/home/fnpauto/abhay/leiyang/it1/32/i86_lsb/publisher
ExecStart=/usr/bin/sh /home/fnpauto/abhay/leiyang/it1/32/i86_lsb/publisher/install_fnp.sh

[Install]
WantedBy=multi-user.target

1.save above script in fnls.service and put it under /etc/systemd/system

2.sudo systemctl daemon-reload

3.sudo systemctl enable fnls.service

4.sudo systemctl start fnls.service.

5.Reboot the server.

Was this article helpful? Yes No
No ratings