Error "invalid license key (inconsistent authentication code)" seen when building toolkit with 11.13.1

Error "invalid license key (inconsistent authentication code)" seen when building toolkit with 11.13.1

Summary

The error "invalid license key (inconsistent authentication code)" is seen (when running with older applications into new server) when building toolkit with 11.13.1 despite all correct steps being followed.

Symptoms

The error "invalid license key (inconsistent authentication code)" is seen (when running with older applications into new server) after building toolkit with 11.13.1 despite all the correct steps being followed.

Cause

When building the toolkit or client application there are two options to use when linking in the 'lmgr' library - lmgr.lib & lmgr_trl.lib.
The former includes all the code you need for backward compatibility, whilst the latter only includes the 'TRL' code -the reason being that if you don't need backward compatibility then it is more secure to use the trl version as this closes an option that hackers could use to attack the security via the older code.

Up to version 11.13.0.3 the default option in the makefile was lmgr.lib(for backward compatibility), whilst with the new release (11.13.1) the default is lmgr_trl.lib (for better security).

The outcome is that if you need backward compatibility then you need to edit the makefile to 'undo' these changes -


Resolution

- Open the makefile in a text editor
- Search for instances of 'lmgr_trl' and change them to 'lmgr'
- This will require changes on lines 50 (change to 'LMGRNAME='), 118, 120, 149 & 189
- Alternatively use the makefile from the older version (11.13.0.x) but add 'Shlwapi.lib' and dhcpcsvc.lib
to the end of the list for XTRALIB1 on line 89

XTRALIB1 = oldnames.lib kernel32.lib user32.lib netapi32.lib \

advapi32.lib gdi32.lib comdlg32.lib comctl32.lib wsock32.lib shell32.lib \

Rpcrt4.lib oleaut32.lib Ole32.lib Wbemuuid.lib wintrust.lib crypt32.lib Ws2_32.lib psapi.lib Shlwapi.lib dhcpcsvc.lib

Update -
For the 11.14 version the lines that would need editing are -
Windows 32 bit -
50 (change to 'LMGRNAME='), 137, 139, 174 & 214
Windows 64 bit - 48 (change to 'LMGRNAME='), 136, 138, 173 & 213
Linux 64 bit - 86, 167, 171, 172, 175 & 178.

Update 2 -
For the 11.14.1 version the lines that would need editing are -
Windows 32 bit - 50 (change to 'LMGRNAME='), 141, 143, 178 & 218
Windows 64 bit - 48 (change to 'LMGRNAME='), 140, 142, 177 & 217
Linux 64 bit - As above

Was this article helpful? Yes No
100% helpful (1/1)
Version history
Revision #:
1 of 1
Last update:
‎Nov 14, 2018 10:43 PM
Updated by: