cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
odenbach
Pilgrim

lmgrd 11.14.1 only logs timestamps but no license usage info

Hi,

I recently upgraded our license servers from 11.14.0.2 to 11.14.1.1. Since then our logs only contain timestamp lines:

4:34:05 (lmgrd) TIMESTAMP 1/3/2018
10:34:05 (lmgrd) TIMESTAMP 1/3/2018
16:34:05 (lmgrd) TIMESTAMP 1/3/2018

No license usage is logged. This makes our license usage statistic tool fail horribly and makes debugging impossible.

I start the server with the options

# /usr/sbin/lmgrd -l +/var/log/flexnet/flexnet.log -local -c /etc/flexnet

This has been working for years but now suddenly stopped generating useful information.

Is this a known behaviour? Or even worse - is this a desired behaviour?

Thanks,

Christopher
Tags (4)
0 Kudos
4 Replies
odenbach
Pilgrim

More logging error details

Hi,

I just found something interesting: lmgrd 11.14.1.1 does log user access, but only from vendor daemons with the same version!

Our license server contains several licenses with several vendor daemons, each with a different version:

[CODE]root@kiso[flexnet]# ls -1 *.lic
ABAQUSLM.lic
alterad.lic
BLUESPEC.lic
INTEL-2017.lic
INTEL_AdvXEl.lic
INTEL.lic
LMCOMSOL.lic
mgcld.lic
orglab.lic
xilinxd.lic
xilinxd-SDAccel.lic

[/CODE]Vendor daemon versions are:

  ABAQUSLM: UP v11.6
BLUESPEC: UP v10.1
INTEL: UP v11.14.1
LMCOMSOL: UP v11.5
alterad: UP v11.13.1
mgcld: UP v11.11
orglab: UP v11.13.1
xilinxd: UP v11.13.1


But the log only contains OUT lines from the INTEL vendor daemon which is 11.14.1:

[CODE]root@kiso[flexnet]# grep OUT flexnet.log | tail -5
10:53:49 (INTEL) OUT: "FCompL" ro89fi@fe1
10:53:50 (INTEL) OUT: "I3CD0D19D" ro89fi@fe1
10:53:50 (INTEL) OUT: "FCompL" ro89fi@fe1
13:53:39 (INTEL) OUT: "I3CD0D19D" mahale@fe2
13:53:39 (INTEL) OUT: "CCompL" mahale@fe2

root@kiso[flexnet]# grep OUT flexnet.log | grep -v INTEL
root@kiso[flexnet]#
[/CODE]

I am sure that there is other license usage:

[CODE]root@kiso[flexnet]# lmstat -f quartus | grep '\(dev\|alterad:\)'
alterad: UP v11.13.1
kenter fe-1.cc.pc2.uni-paderborn.de /dev/pts/25 (v2016.05) (kiso.uni-paderborn.de/27000 137), start Tue 1/9 12:12
[/CODE]

This breaks our setup of having one single lmgrd running with several license files.

Anyone having the same issue? Any idea how to circumvent it?

Thanks,

Christopher
0 Kudos
raffie
Flexera beginner

Re: lmgrd 11.14.1 only logs timestamps but no license usage info

I just tried an 11.14.1.2 lmgrd with an 11.13.1.3 vendor daemon and it logged the checkouts. But I only had one vendor daemon.
Do you happen to have an options file for the other deamons that might be changing the debug log location?

Eric
0 Kudos
odenbach
Pilgrim

Re: lmgrd 11.14.1 only logs timestamps but no license usage info

raffie wrote:
I just tried an 11.14.1.2 lmgrd with an 11.13.1.3 vendor daemon and it logged the checkouts. But I only had one vendor daemon.
Do you happen to have an options file for the other deamons that might be changing the debug log location?

Eric


I use an option file for each vendor daemon but I do not set anything about the debug log location. I would like to try version 11.14.1.2 but unfortunately I do not know where to get it from. INTEL only provides 11.14.1.1 which shows the problem. Any idea where it is available?

Thanks,

Christopher
0 Kudos
odenbach
Pilgrim

[SOLVED] lmgrd 11.14.1 only logs timestamps but no license usage info

Hi,

I just found version 11.14.1.2 somewhere - and the bug is fixed!

Thanks,

Christopher
0 Kudos