Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 4

Trusted storage - No such feature exists "ADD"


trying to evaluate the trusted storage option for flexera publisher.

i was able to load ASR in trusted storage. then configured and ran the vendor daemon as well.from the browser i was able to see that fulfullment is also available. however when i ran lmflex exe to checkout ADD i get the error. "no such feature exists"

i tried the lmflex with "f1" and this time it worked, but i can see this is provided in token license file to start the vendor daemon. vendor daemon is not able to get feature from the trusted storage.

running servercomptranutil also gives expected result and shows 10 hybrid licenses.

need some help with this step

0 Kudos
(8) Replies
Flexera Alumni

Hi @venu_gopal  ,

When you start the server , can you see the statement that "TS is being accessed" if yes is ADD getting displayed as one of the available features.?

When you run servercomptranutil -vl are you able to see "Add" being served .Can you share the output ?

0 Kudos

@jyadav wrote:

Hi @venu_gopal  ,

When you start the server , can you see the statement that "TS is being accessed" if yes is ADD getting displayed as one of the available features.?

When you run servercomptranutil -vl are you able to see "Add" being served .Can you share the output ?

when i start server, i get this message in log

10:50:22 (lgcx) (@lgcx-SLOG@) FlexNet Licensing Service Version:
10:50:22 (lgcx) (@lgcx-SLOG@) Is TS accessed: Yes
10:50:22 (lgcx) (@lgcx-SLOG@) TS access time: Fri Sep 17 2021 10:50:22 Coordinated Universal Time
10:50:22 (lgcx) (@lgcx-SLOG@) Number of VD restarts since LS startup: 0


when running servercomptranutil -vl   i get following response. it does mention ADD feature

Screenshot 2021-09-17 at 3.50.04 PM.png


may be i am doing some wring configuration. 

0 Kudos

Hi @venu_gopal  From the above output it looks like the feature ADD is being served . 

You can raise a case with us with the TS file , event logs and the serveractutil -vl output along with the error that you are facing while checking out the license

i have just noticed that in the feature it says 'INCREMENT ADD demo...'

however the vendor daemon i am running is named lgcx. can this be the reason for the ADD feature not working. 

i can change the demo to lgcx in ASR but how will i be able to generate new signature for it.


0 Kudos

Build the TS kit for vendor " lgcx ".

To load License Rights From the ASR for lgcx , make sure you have it corresponding publisher id which is replaced in the ASR.

The xmlsign utility signs XML documents used for activation based on seeds defined in the activation settings file.

xmlsign -a as_file -i infile -o outfile

Using the seeds provided in the activation settings file, a private key is generated and used to add a signature to
every section in the infile that has a “Signature” element.

 • xmlsign Utility
Input Description
-a as_file The pathname to an activation settings file (S_ActivationSettings.xsd).
-i infile The pathname to an XML document. The following documents must be signed:
• Activation specification record, ASR (B_ActivationSpecificationRecord.xsd)
• Trusted Configuration (P1_ConfigPhaseTwo.xsd)
-o outfile The pathname of the resulting signed XML document.

To load the license rights into trusted storage
1. At a command prompt from the <platform_dir> directory, enter the following:
servercomptranutil -local ..\examples\ezcalc\30day_trial_server\30day_trial_server.asr
The following confirmation message is displayed:
Local activation, ASR ..\examples\ezcalc\30day_trial_server\30day_trial_server.asr
Local activation successful
This command should have loaded ten hybrid licenses for EZCalculator Accountant into license-server trusted storage. Additionally, because prepped Trusted Configuration was in effect for this demonstration,
the servercomptranutil activation utility, not the ASR execution, configured the initial trusted section into which the licenses were loaded.
2. To confirm the contents of trusted storage, enter the following:

servercomptranutil -viewlong
This command can be abbreviated and used as appcomptranutil -vl.
The output should be similar to the following, showing a fulfillment record for ten hybrid licenses of the
EZCalculator Accountant edition:
Fulfillment Type : 6 Publisher Activation
Trust Flags : 0x7 Fully Trusted
Status : Enabled
Entitlement ID : ENTL-EZCALC-AS1
Expiration date : 12-jan-2017
Server chain : Server1
Feature Line(s) :
INCREMENT ADD demo 1.0 31-dec-2020 1 TS_OK SIGN="00B1 5DCC A0E1 CF5F \
4D2E 089D 8A3E 8D00 036D 906F C9A0 588A 2A1C 1482 2876"
INCREMENT SUBTRACT demo 1.0 31-dec-2020 1 TS_OK SIGN="00F7 AD8A BCE0 \
7AC8 A454 FE42 ECC3 6600 20DD A746 347A 5285 8B13 B8F6 3ADE"
INCREMENT MULTIPLY demo 1.0 31-dec-2020 1 TS_OK SIGN="002F FFFC 8B6A \
5E90 ADDA E96D 40E5 6000 1CE5 3519 B889 C9BC 3CAD 882B DC2F"
INCREMENT DIVIDE demo 1.0 31-dec-2020 1 TS_OK SIGN="00E4 549A 9880 \
8538 AB39 126B C608 B200 1057 0D1E 523E 9E7E FB63 A297 0291"
INCREMENT AVG demo 1.0 31-dec-2020 1 TS_OK SIGN="0022 F023 3754 4C11 \
F24C F32A 961F C200 3F87 26A4 EB8C 7321 92E8 C2CB B472"
Concurrent : 0
Activatable : 0
Hybrid : 10
Concurrent overdraft : 0
Activatable overdraft : 0
Hybrid overdraft : 0
Repair : 0
Deduction count : 0
The license rights you just loaded into trusted storage are in the hybrid group and are directly available to be
checked out as concurrent licenses. Later on in this section, you will check out a license from these license

i am trying to run the xmlsign.exe 

however when running this i get error

OS error code 0x0000000

any idea what might be causing this error?

also when i run the nmake -f makefile.act i get the error that publisher.xml file parsing error. error on line 3.

0 Kudos

This error "OS error code 0x00000000" is most commonly seen in case of a mismatch in the xml/build process.

Could you check if you are using a supported visual studio version as per the FNP toolkit that you are using .

Also open the publisher.xml and check if the specified keys, publisher id and vendor names are correct  as per the ones shared by Revenera. 

i believe publisher keys can be generated by us. 

however publisher id, is it specified in toolkit somewhere or share by other medium (email). 

0 Kudos