cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Flexera beginner

Can't deploy lmgrd.exe due to virus threat

V11.17.2 lmgrd.exe seems to trigger windows defender.

Any suggestions on how I deploy this ?

0 Kudos
2 Replies
Highlighted
Flexera
Flexera

Re: Can't deploy lmgrd.exe due to virus threat

@paul_carre , can you confirm the Windows OS details here?

Also, if this threat assessment page is displayed by Windows itself or through some other 3rd party tools? Internally Revenera has 100s of windows systems where day in day out (under strict windows firewall) testing is being executed and since we have not seen this internally - it would mean that there has to be some difference in between our environments. It will be helpful to deduct that first.

In the meanwhile, you may want to add the executables under Flexlm directory as exception to the firewall till we have a resolution against this.

(If my response assists with your questions , then please click "ACCEPT AS SOLUTION" or 'Kudos' so that it help others.)
0 Kudos
Highlighted
Flexera beginner

Re: Can't deploy lmgrd.exe due to virus threat

It is displayed by Windows 10 itself. We have two examples producing the same warning one here in my office and the other in our UK office. Attached is the update data for the system I have access to.

Interestingly my development system (Windows 8.1) does not flag an issue. Also interesting is that lmgrd.exe from your version V11.17.1 comes through fine.

I am thinking I may ship the lmgrd.exe from V11.17.1,  what do you think ?

Adding exceptions at customers is not going to work here – we have about 200 customers and two of them strike me as somewhat ironic in this situation :-

The first is a large software vendor HQ in Redmond WA, they may or may not be the author of the offending ‘assumed false positive’ indication (there may or may not be an NDA in place here).

The second is a US weapons-grade military contractor that specifically ‘red flagged’ your code as posing a “significant security vulnerability” and requested ( read that as REQUIRED ) that we move away from using your version V11.13.1.2 to “something later than V11.16”. If I ask them to add an exception in their security – when the laughing stops (pretty quickly, these guys are quite serious) I think I will likely find myself strapped to a broken school bus in the Nevada desert waiting for the next missile test to arrive.

While we are at it I really don't like your forum / chat / bulletin board style of support, it has me flagged as a "Flexnet Beginner" - I am a CUSTOMER and as it happens I sign off on your yearly invoice and have done so every year since 2003. A couple of years back I was a guest presenter at one of your seminars - in short I feel a bit insulted.

Paul C

0 Kudos