cancel
Showing results for 
Search instead for 
Did you mean: 
nico_sijtsma2
Flexera beginner

11.15.1 license server does not append logs after restart

We have our product running on FNP version 11.15.1 When the license server is restarted, the log file is cleared, while we have the OPT file configured to append the log using DEBUGLOG +"C:\ProgramData\FLEXlm\lmgrd\JSdebug.log" Opening the log file confirms the opt file is picked up when the file is read 15:43:30 (xxx) Debug log started (+C:\ProgramData\FLEXlm\lmgrd\JSdebug.log). If i pull up the properties of the log file, i can see the creation date is still 2018, but it did update it as an empty file. We see this issue on 2 of our internal license servers. Let me know if you have a fix for this. We want to retain our debug logs. Nico
0 Kudos
6 Replies
Flexera aparashar1
Flexera

Re: 11.15.1 license server does not append logs after restart

Hi Nico, The Creation date is an expected observation, as "+" - append notation confirms that daemon will update the existing file. Since the file already exists during restart, hence there is no need to recreate it. So, the creation date is in future. I am not sure what did you mean by "but it did update it as an empty file". Could you clarify please? In case if a debug log is appended, the last modified time will not be changed until either server is brought down (i.e. VD clears the file pointer) or we edit the file. Regards, Abhay
0 Kudos
nico_sijtsma2
Flexera beginner

Re: 11.15.1 license server does not append logs after restart

The problem im trying to explain is that everytime the server restarts, or even a lmgrd stop-start, the log is cleared. Though all signs show its suppose to update, the old info is gone, its a clean file, with a new process startup header and no checkout lines.
0 Kudos
nico_sijtsma2
Flexera beginner

Re: 11.15.1 license server does not append logs after restart

I just reproduced it on a new machine Using the 11.15.1 x86 binaries on x64 system, copy them into a Folder and run lmgrd.exe Create a new license server, point to a valid license file and configure a log path. Create a vendor daemon options file and define the debuglog path DEBUGLOG +"C:\ProgramData\FLEXlm\lmgrd\debug.log" Start the license server Checkout a license Close the software Stop the license service Check the log file for the stop line Start the license server Check the log file > Its cleared, a new header shows
0 Kudos
Highlighted
rgering
Flexera beginner

Re: 11.15.1 license server does not append logs after restart

Hello Nico,

The logfile you specify via DEBUGLOG in the OPT file gets switched to after lmgrd has already been logging to the logfile it received via the -l option.

If you can see:

Debug log started (+C:\ProgramData\FLEXlm\lmgrd\JSdebug.log)

in the file C:\ProgramData\FLEXlm\lmgrd\JSdebug.log itself, that would mean lmgrd -l and DEBUGLOG point to the same file. There's no problem with this (although you don't really need DEBUGLOG at that time), but you'll have to make sure both -l and DEBUGLOG are using a path starting with a "+" to enable append mode. Without it, lmgrd would empty out the file on restart before DEBUGOPT gets a chance to switch it to append mode.

Kind regards,

- Richard.

nico_sijtsma2
Flexera beginner

Re: 11.15.1 license server does not append logs after restart

ah ok i will give that a go. 

We have been using this for years, but since upgrading to 11.15.1 the behavior changed, is that possible ?

In the past we configured it the same way and had no issues.

So we can also create 2 separate log files and that should be good. 

0 Kudos
rgering
Flexera beginner

Re: 11.15.1 license server does not append logs after restart

I'm not sure if the behavior changed in v11.15.1, but having spent a lot of time around log files recently (albeit with v11.16.x) I'm not surprised if a mismatch between append and non-append would cause this.

Could you perhaps avoid having to use the .opt file for this purpose and have all logs be written in append mode starting with lmgrd, by using -l "+LogFilePath"? The installs.exe service installer supports this option as well. (Ignore the path creation errors you might get running installs.exe with a path starting with a +, as that program unfortunately has a number of bugs.)

Cheers / met vriendelijke groet,

- Richard.

 

0 Kudos