- Revenera Community
- :
- FlexNet Operations
- :
- FlexNet Operations Knowledge Base
- :
- Deploy all takes much longer than expected, what is the cause and how to reduce the Deployment time
- Mark as New
- Mark as Read
- Subscribe
- Printer Friendly Page
Deploy all takes much longer than expected, what is the cause and how to reduce the Deployment time
Deploy all takes much longer than expected, what is the cause and how to reduce the Deployment time
Symptoms:
This article explains the Flexnet Operations Application deployment or Deploy All is taking a long time than expected, how to find what was the cause and how to fix it.
Diagnosis:
If Deployment is not failed but it was taking more time than expected or if you are seeing the time to complete the deployment is increasing every new deployment then there might be lots of Import/Export files or Data Extract files in the ADMN directory and .prd files in the prd directory located in this below path
C:\FlexNetOperations\components\wildfly\standalone\deployments\flexnet.ear\flexnet-data\data\ADMN
C:\FlexNetOperations\components\wildfly\standalone\deployments\flexnet.ear\flexnet-data\data\prd
Solution:
To fix this issue, try to clear these files after taking backup regularly under the below listed path to speedup the Deployment and reduce the deployment time
C:\FlexNetOperations\release\flexnet-data\data\ADMN
C:\FlexNetOperations\release\flexnet-data\data\partdatatemp
C:\FlexNetOperations\release\flexnet-data\data\prd
C:\FlexNetOperations\release\flexnet-data\data\wrkdatatemp
- Where the ADMN directory will have the Import/export and data extract files if the file location configured as default.
- partdatatemp directory will have partnumber related XML temp files
- wrkdatatemp directory will have WebRegKeys related XML temp files and
- prd directory will have FNP license activation related prd temp files, read more about prd files click here