- Revenera Community
- :
- FlexNet Embedded
- :
- FlexNet Embedded Knowledge Base
- :
- Running LLS flexnetlsadmin reports error "glsErr.serverNotFound"
- Mark as New
- Mark as Read
- Subscribe
- Printer Friendly Page
- Report Inappropriate Content
Running LLS flexnetlsadmin reports error "glsErr.serverNotFound"
Running LLS flexnetlsadmin reports error "glsErr.serverNotFound"
Symptoms:
Running LLS admin utility flexnetlsadmin.bat, the LLS gives on screen error "glsErr.serverNotFound" as shown in below screenshot although LLS is up and running fine and have valid licenses in it's TS.
Diagnosis:
It's observed that in few cases or in few machines when a user executes the flexnetlasadmin utility as shown in above screenshot, LLS reports below detailed error logs in flexnetls.log
17:39:08,393 ERROR - Unknown server instance : health
17:39:08,406 INFO - handleResourceNotFoundException Unable to process request:Server instance not found: health
17:39:22,876 INFO - Unknown server instance (cached as bad) : health
17:39:22,876 INFO - handleResourceNotFoundException Unable to process request:Server instance not found: health
The above errors were reported because LLS was trying to access the LLS instance ID, which was not available or was not correct. It was found that in those problematic machines, FLEXNETLS_BASEURL was configured wrongly in the system environment variables.
Solution:
Fix the system environment variable for FLEXNETLS_BASEURL and the correct format should be like below.
FLEXNETLS_BASEURL=http://localhost:7070/api/1.0/instances/~