cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error "Features are not available due to a rule rejection" while checking out license from CLS

Error "Features are not available due to a rule rejection" while checking out license from CLS

Symptoms:

While checking out licenses from CLS the error "Features are not available due to a rule rejection" is observed.

Diagnosis:

This error is possibly due to the mismatch on the parameter on which the request sent to the CLS to checkout licenses than the already available rules/model/feature selectors at CLS. This means if the request doesn't contain the feature selectors that is already available at CLS, then you may receive this error.

One can verify the current existing rules against a CLS instance by sending the GET calls against /rules endpoint.

For example: https://flexXXXX.compliance.flexnetoperations/api/1.0/instances/<CLS_ID>/rules

Solution:

One need to update the rules first on CLS, on which the license checkout is expected. The rule update can be done by sending a model update POST call against /rule endpoint. Following is a sample request body which defines rules to checkout licenses only on specific hosts.

 

 

model "test" { on hostid("Test1223+","gkasgfkA2124") { use "default" accept } on any() { deny } }

For more information on /rules POST call, see the LicenseServer Producer Guide.

 

NOTE:  Feature Selectors and feature partition should not be used at the same time, as it may produce unexpected errors. This is noted in the License server producer guide under the section "Limitations of Partitions".

 

 

Labels (3)
Was this article helpful? Yes No
No ratings
Version history
Last update:
‎Jun 30, 2022 03:49 AM
Updated by:
Contributors