cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
oversampled
Flexera beginner

MacOS 10.15 Notarization of FNE Clients will require library update.

An update to the FNE libraries is urgently required to address the Apple notarization requirements.

Currently the 2019.11 libraries are built using OSX SDK 10.8.  It is a requirement for notarization that all libraries are built using SDK10.9 or later.

It would be reassuring to hear some news about this.

 

 

3 Replies
Flexera tphamda
Flexera

Re: MacOS 10.15 Notarization of FNE Clients will require library update.

We apologize for the late reply due to the holiday period. Our engineers are aware of this issue with notarization and are working on a solution. However, we do not have any additional details to provide at this time. 

Mx-Andy
Flexera beginner

Re: MacOS 10.15 Notarization of FNE Clients will require library update.

Hello,

we have the same issue and need the signed libs, since apple will reject unnotarized applications on 10.14 with the start of february; unless you disable it in gatekeeper.

 

Best Regards

 

0 Kudos
stevebaxter
Pilgrim

Re: MacOS 10.15 Notarization of FNE Clients will require library update.

This is now an emergency. As of yesterday, Apple are now enforcing their notarisation rules, and the FNE libraries don't meet the requirements. This means that we are no longer able to ship any products that use FNE.

    {
      "severity": "error",
      "path": "xxx/Versions/A/Frameworks/libFlxCore.2017.02.dylib",
      "message": "The signature algorithm used is too weak.",
      "docUrl": null,
      "architecture": "i386"
    },
    {
      "severity": "error",
      "path": "xxx/Versions/A/Frameworks/libFlxCore.2017.02.dylib",
      "message": "The binary uses an SDK older than the 10.9 SDK.",
      "docUrl": null,
      "architecture": "i386"
    },

Please can you tell us when an update will be available?

Cheers,

Steve

0 Kudos