cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
m_radulovic
Level 3

Local License server picking VM_UUID

Hi there,

Any idea why would Local License server (flexnetls.jar, version 2020.07.0) pick VM_UUID when not configured to do so?

It is running on VM in Citrix environment. It initially picked MAC address for ID. This is default behavior. It worked like that for a while and now it shows that it switched to VM_UUID. It was not configured for that in flexnetlsw.xml. Furthermore it shows this as response to ID request (notice no ethernet ID at all):

{
"hostids" : [ {
"value" : "15777EEC-3C24-6240-907F-077B95BXYZ23",
"type" : "VM_UUID"
} ],
"selected" : {
"value" : "15777EEC-3C24-6240-907F-077B95BXYZ23",
"type" : "VM_UUID"
}
}

Please not the actual ID is not real. I changed it, to avoid publishing customer specific data to public forum.

Many thanks,

Milisav Radulovic

0 Kudos
3 Replies
jberthold
Revenera Moderator Revenera Moderator
Revenera Moderator

Hi @m_radulovic ,

It appears the SDK is not picking up the MAC address, is there an issue with your ethernet interface (is it disabled)?  Not sure what OS you are running, is the MAC address shown with ipconfig/ifconfig?

Thx,

Jim

0 Kudos

Hi Jim,

This is running on Windows, ethernet adapter is not disabled. It shows up in ipconfig /all. VM has 3 ethernet adapters. All enabled. Previously, license server used MAC address of one of the adapters for ID. See below.

Thanks.

Ethernet adapter Public Network:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Xen Net Device Driver
Physical Address. . . . . . . . . : 00-17-4E-C4-C2-09
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::ac49:cafe:777e:da3b%11(Preferred)
IPv4 Address. . . . . . . . . . . : 86.87.255.186(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.254.0
Default Gateway . . . . . . . . . : 86.87.254.1
DHCPv6 IAID . . . . . . . . . . . : 50337342
DHCPv6 Client DUID. . . . . . . . : 11-01-22-01-24-92-F6-CA-00-16-3E-C4-C2-09
DNS Servers . . . . . . . . . . . : 11.2.175.62
11.2.175.61
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Private Network:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Xen Net Device Driver #2
Physical Address. . . . . . . . . : 00-17-4E-E2-0B-96
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 11.2.175.60(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : 11.2.175.62
10.0.165.61
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Storage Network:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Xen Net Device Driver #3
Physical Address. . . . . . . . . : 00-17-4E-A8-05-BF
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::a04d:54bb:a498:74ac%4(Preferred)
IPv4 Address. . . . . . . . . . . : 11.2.30.52(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 83891774
DHCPv6 Client DUID. . . . . . . . : 00-01-11-01-24-92-F6-CA-00-16-3E-C4-C2-09
DNS Servers . . . . . . . . . . . : 11.2.175.62
11.2.175.61
NetBIOS over Tcpip. . . . . . . . : Enabled

0 Kudos

Thanks Milisav,

I'm not sure why the MAC addresses aren't being picked up.  Please submit a ticket so that someone from support can work with you to resolve.

Best regards,

Jim

 

0 Kudos