cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Flexera beginner

Identity mismatch in binary request

I try to get the license from an activation ID and first call TalkToServer as in the example. That function returns true.

Next I call FlcProcessCapabilityResponseData to get the response, but then I get this error: "Identity mismatch in binary request".

I tried the CapabilityRequest example with the same result.

Any idea what the problem might be? The identity object is the the one I download from Administrer->Identities (we only have one).

0 Kudos
4 Replies
Flexera beginner

Re: Identity mismatch in binary request

I'm using this server address that I get from System configuration -> Licensing: https://flexerasoftware.compliance.flexnetoperations.com/instances/xxxxxxxxxxx/request 

Is that the correct server address to use?

0 Kudos
Revenera Moderator Revenera Moderator
Revenera Moderator

Re: Identity mismatch in binary request

Hi @Marcus ,

No, that is not the correct activation endpoint.  The endpoint you referenced in FlexNet Operations under System Configuration / Licensing is a Revenera server that contains the licenses to enable the FlexNet Operations modules that your company has purchased.

If you are activating a FlexNet Embedded enabled application using an Activation ID with FlexNet Operations, the  Endpoint you wish to use is the following:

Production:

FlexNet Embedded Activation Endpoint

https://<siteID>.compliance.flexnetoperations.com/deviceservices

UAT:

FlexNet Embedded Activation Endpoint

https://<siteID>-uat.compliance.flexnetoperations.com/deviceservices

 

where <siteID> is your FlexNet Operations instance (which initially for FlexNet Operations ALM is something similar to flexNNNN)

 

Link in FNO User Guide to section referencing FNO Environment URLs:

https://docs.revenera.com/fno2021-01/producer/Content/helplibrary/opsOpsEnviromentProd.htm#fno_admin...

Thanks,

Jim

0 Kudos
Flexera beginner

Re: Identity mismatch in binary request

Thanks!
It turned out that this was the correct URL to use: https://<siteID>-uat.flexnetoperations.eu/flexnet/deviceservices
0 Kudos
Revenera Moderator Revenera Moderator
Revenera Moderator

Re: Identity mismatch in binary request

Thanks @Marcus ,

As a reference to others seeing this post, I can see by the ".eu" in the URL you are using a version of FNO Cloud that is hosted on AWS in EMEA.

Thx,

Jim

0 Kudos