cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
swarnsingh
Flexera beginner

Flexnet embedded local licence server json security

Jump to solution

Hi,

After setting up and activating a  local licence server, then trying to checkout a licence using the rest API end point "access_request" I get the following error :-

 {
"key": "glsErr.jsonLicensingSecurityNoToken",
"message": "Valid token required for secure JSON licensing request.",
"arguments": [
"uri=/api/1.0/instances/FX7WFQDN7883/preview_request",
"(unknown)"
]
}

After reading the documentation it seems the API points are secured with JWT because of the setting in producer-settings.xml (by default).

licensing.security.json.enabled=true.

I changed this to false in producer-settings.xml on the local server, stopped and restarted the licence server but this does not seem to make any difference. According to the API /configuration my  security configuration is still true.....

{
"id": "security.enabled",
"values": [
"false"
],
"parentValues": [
"false"
]
},
{
"id": "security.token.duration",
"values": [
"1d"
],
"parentValues": [
"1d"
]
},
{
"id": "security.http.auth.enabled",
"values": [
"true"
],
"parentValues": [
"true"
]
},
{
"id": "licensing.security.json.enabled",
"values": [
"true"
],
"parentValues": [
"true"
]
},

What are the steps to set licensing.security.json.enabled to false on the local licence server so that I don't get the valid token error?

Any help would be greatly appreciated.

0 Kudos
1 Solution

Accepted Solutions
swarnsingh
Flexera beginner

Re: Flexnet embedded local licence server json security

Jump to solution

In case this is of any use to someone, I found the solution in the document FNE_LicenseServerGuide_2019R1SP1.pdf.

The steps to change the settings of a local licence server that is already installed are :-

1) Create a text file for the changed settings that need to be changed e.g.

licensing.security.json.enabled=false

and name it properties.txt

2) Locate the bin\tools directory in the installation directory of the local licence server

3) Make sure the flexnetconfig.bat file is there , move files IdentityClientServer.bin and properties.txt into that folder

4) Run the command

flexnetlsconfig -prop properties.txt -o producer-settings.xml -id IdentityClientServer.bin

this will recreate file producer-settings.xml

5) Move the file into the server directory, for example flexnetls-x64_windows-2019.05.0\server (the same file can be used for other local licence server installations on other servers too)

6) Stop and restart the flexnet local licence server in windows services

The setting should now be false and allow rest API calls to endpoints like /access-request without needing an authorisation header JWT.

0 Kudos
1 Reply
swarnsingh
Flexera beginner

Re: Flexnet embedded local licence server json security

Jump to solution

In case this is of any use to someone, I found the solution in the document FNE_LicenseServerGuide_2019R1SP1.pdf.

The steps to change the settings of a local licence server that is already installed are :-

1) Create a text file for the changed settings that need to be changed e.g.

licensing.security.json.enabled=false

and name it properties.txt

2) Locate the bin\tools directory in the installation directory of the local licence server

3) Make sure the flexnetconfig.bat file is there , move files IdentityClientServer.bin and properties.txt into that folder

4) Run the command

flexnetlsconfig -prop properties.txt -o producer-settings.xml -id IdentityClientServer.bin

this will recreate file producer-settings.xml

5) Move the file into the server directory, for example flexnetls-x64_windows-2019.05.0\server (the same file can be used for other local licence server installations on other servers too)

6) Stop and restart the flexnet local licence server in windows services

The setting should now be false and allow rest API calls to endpoints like /access-request without needing an authorisation header JWT.

0 Kudos