JRE libraries are missing or not compatible error during FlexNet Code Insight installation

JRE libraries are missing or not compatible error during FlexNet Code Insight installation

Symptoms:

The following error may be encountered during an installation of FlexNet Code Insight:

Preparing to install 
Extracting the JRE from the installer archive... 
Unpacking the JRE... 
Extracting the installation resources from the installer archive... 
Configuring the installer for this system's environment... 
Launching installer... 
JRE libraries are missing or not compatible.... 
Exiting....

Diagnosis:

This issue is typically caused by insufficient privileges on the 'tmp' directory

Solution:

To correct this issue, cutomers will need to create a new "temp" directory in a location where you do have the proper permissions (for example, /opt/fnci/tmp), and then set an environment variable called "IATEMPDIR".  Example:

mkdir /opt/fnci/tmp

export IATEMPDIR=/opt/fnci/tmp

You should now be able to successfully launch the installer without encountering the "JRE libraries are missing or not compatible" error.

Was this article helpful? Yes No
No ratings
Version history
Revision #:
1 of 1
Last update:
‎Jul 12, 2019 07:47 AM
Updated by:
 
Contributors