justinb
Occasional contributor

How do you launch the detector client if you don't want to install Oracle JDK?

I am trying to run the detector client, but don't want to install Oracle JDK.  I have OpenJDK installed on my machine, but I can't get the JNLP files to run.

Thanks.

Labels (1)
0 Kudos
5 Replies
mkumari
Revenera
Revenera

We cannot launch detector client with any version of Open JDK. Oracle JRE 8 (64-bit) (update 172) is required on client server to launch Detector.
In general, use the latest Java update when possible.

Download link: http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html

0 Kudos
mruscetta
Occasional contributor

Starting with FNCI 6.13.0,  The Release Notes and Admin guide indicate that  Zulu OpenJDK 8 (64-bit from Azul) is supported. 

Does your comment above mean that Zulu OpenJDK is supported for core & scan servers only, and not for the detector client?

This is not indicated in current documentation.

thanks,

  Michelle

0 Kudos

Zulu OpenJDK is supported for core & scan servers only. 

In FNCI 6.13.0 and above Admin guide(FlexNet Code Insight 6.13.0 Installation and System Administration Guide -> Prerequisites -> Software), it is mentioned that Oracle JRE 8(64 bit) is required on client server to launch Detector.

Thanks,

Medha

0 Kudos
mruscetta
Occasional contributor

Thank you, Medha.  My apologies -- I overlooked the Oracle JRE requirement stated in the guide.

Do you know if there are any plans to support OpenJDK in the detector client?

 

thanks,

  Michelle

0 Kudos

No, we won’t be able to support detector client using any other JRE as OpenJDK doesn’t support Java Web Start which is required for launching detector.

0 Kudos