andrei756
Level 3

Cant install

Hi

Ive created an installpackage and my main issue is that it installs until it needs to start the services that are needed for my application to run. It tells me to check if i have enough rights to do so.
I have some errors due to some dependencies from DevExpress. But I have no errors!

Hope you can help me out with this. Im struggling about over a week now to get this solved by myself.
Labels (1)
0 Kudos
2 Replies
Christopher_Pai
Level 16

You are most likely gettign a generic 1920 error message. While the installer is stuck at that point try to start the service manually from the command line. It should fail.

You are going to have to understand why the service won't start. It could be some code throwing an exception, it could be your missing a dependency or it could be that your service account doesn't exist and doesn't have the correct access rights.

Solve that mystery and your installer will start working.

PS- One habit I've developed over the year is to add the ServiceInstall but not the ServiceControl events for new services. I don't add the ServiceControl until the service has proven stable so that developers don't blow up the install with their problems and come to me for problems that aren't my problem.
0 Kudos
andrei756
Level 3

Hi

Thank you for your very insightful reply. I am new to this topic so please excuse me if i have some - "duh :rolleyes: " questions!

I guess that my service account doesnt exist or does not have the correct access rights. I havent set those things. where can I do that.
I have a lot of dependency warnings due to devexpress but no matter what I do i still get those. My program works well in visual studio no known exceptions at the moment.

I didnt add SeviceInstall or ServiceControl because I dont really know what this is :rolleyes:

Thanks a gain I really appreciate all kind of help
0 Kudos