loring
Level 2

Silent install one package in Suite project

Hello,

I'm new to Installshield, created a suite installation including 5 MSI packages. when install the SQL Server Native Client package named "sqlncli.msi", prompt an error message that "IACCEPTSQLSERVERLICENSETERMS=YES" is required, refer attachment.
My question is how could I add this parameter to this package?

Thank You!!
Labels (1)
0 Kudos
3 Replies
DebbieL
Level 17

You should be able to pass command-line parameters through the command-line settings in the Packages view. In the Packages view, expand the operations such as Install, and then configure the command-line settings (that is, enter IACCEPTSQLSERVERLICENSETERMS=YES) as needed.
0 Kudos
loring
Level 2

Hi Debiel,

Actually, I have tried the method you mentioned, but still not working.
I typed different commands in the command line of package view, either will met the same error as above, or the installation will be interrupted.

Do you know the exact commands I should type in the command line setting?
I have tried "IACCEPTSQLSERVERLICENSETERMS=YES", or "msiexec /i IACCEPTSQLSERVERLICENSETERMS=YES", both failed.

Thanks a lot
0 Kudos
DebbieL
Level 17

Hmm. It looks like we have a typo in our posts. I simply copied/pasted the property name from your post. However, the screen shot has a slightly different property name:
IACCEPTSQLNCLILICENSETERMS


So perhaps you need to enter the following for the command-line settings:
IACCEPTSQLNCLILICENSETERMS=YES
0 Kudos