Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

Offline Activation Failed - Error 51311


I've been using InstallShield 2015 for about a year now without any issue. Today I tried to use the application and it asked me to do an activation for some reason.

It won't do the on-line activation - it fails, so I'm trying the offline activation. When I put in the activation file after going out to the website and registering it says: "The offline transaction failed. Make sure that the response text is properly formatted." Then it says it's "Error: 51311 - One or more response actions failed" That error code isn't listed on the help link.

Does anyone know how to fix this? Also does anyone know why I have to re-register the product?

Labels (1)
0 Kudos
(3) Replies
Level 3

So if anyone else has this issue, here is what kind of helped me:

My issue has to do with the VM hardware changing so I have to do another special step. What a hassle.
0 Kudos
Level 4

Same issue here with AdminStudio 2016- upgraded AdminStudio 2016 to 2016 SP1, and get the 51311 error with InstallShield.
Stuck on offline activation - that btw - doesn't work either. I have tried uninstalling and reinstalling AdminStudio to "return" my license - doesn't work - just get the same pointless offline activation prompt again.

Why does software that is being upgraded on the SAME hardware have to reactivate? As a software company, you would think Flexera would understand software.

Same bug has existed since Installshield/AdminStudio 2014.
0 Kudos
Moderator Moderator


Please try the below steps to resolve this issue: 

1. Open Regedit and navigate to HKEY_CURRENT_USER\Software\InstallShield\22.0  version. 

2. Change the value of all the registry keys available to 0 then close Regedit. 

3. Open InstallShield 2015 and attempt offline activation. 

Make sure that you return the license first from the original machine then only try activation in your same machine. Please let me know if these steps worked for you or not.

Pratik smit Sahoo
0 Kudos