Loading
vCenter VMWare inventory doesn't work with Discovery and Inventory Rules

Hello community,

 

As my last post about this issue was mysteriously deleted by the interface "update" here, I'll post the issue again. (deleted post - vCenter VMWare inventory doesn't work with Discovery and Inventory Rules -URL No Longer Exists)

 

My issue is with the Discovery and Inventory rule, it's not working properly and it doesn't audit any data for two vCenter IPs.

 

But running the ESXQuery tool on the beacon server gives me 22 devices for each IP, including the vCenter itself, so a total of 44 .ndi files are generated while using the ESXQuery tool. I'm using the same Service Account used on the beacon application.

 

You can check how the "Action" part of the rule is created in the screenshot D&I SS1.

As for targets, I've added the two vCenter IPs I'm trying to audit.

IPs are added under Subnets to the correct beacon

vCenters are created under discoverable devices

Service account is added on Beacon, having the right permission( clearly as it works on the ESXQuery tool without issues)

Service account is filtered on the two IPs.

 

 

So everything is done "by the book" and still the rule fails to work.

It only returns the error found attached as D&I SS2. Also see D&I SS3 for the result after running the rule.

 

This error is unrelated to my issue as stated in a Community post that is now also unreachable Remote execution fails with error 'port 135 is not open' - but I've managed to take a look at the post before the interface "update"

 

For the moment I've created a script that will run the ESXQuery daily and move the resulted .ndi to the Incoming directory, so they get uploaded. But I'd like for this rule to work without any scripts needed.

 

Anybody has a solution for this issue?

 

Thank you.


    • Hi @mfranz​ ,

       

      Yes, I've checked every log and no errors shown besides this one attached.

      Any specific file I should check?

      • DeviceInventory
      • RPC (Remote Procedure Call) is used for general remote inventory of the computer. When RPC ports are not available or the user is not entitled for RPC, you'll get this error.

         

        Best practice is to have a pure VMware task, with the "Gather hardware and software inventory from all target devices" option disabled.

        Expand Post
      • I've disabled the option, that seemed to take care of the "failed" error, but still no devices are inventoried.

         

        2 devices discovered (the vCenters) and 0 inventoried, with this message showing: "Discovery shows that this device is a Windows or a UNIX device but the rule 'DHC vCenters' does not allow for inventory gathering."

        Expand Post
  • That is a normal result if "inventory gathering" is disabled. Could you please check "Discovery.log" and "VMWareInventory.log" files from the latest inventory rule execution?

  • Looks like discovery could not identify the VMware service API. Could you double check if your Beacon can access the the port that you set up in the "All Discovered Devices" view (usually 443)?

  • Maybe this post with a similar issue might be helpful.

     

    Also, if you know the two vCenters you're trying to reach, try specifying them as the target and not bother doing Discovery - just have the rule do Inventory.

     

    --Mark

    Expand Post

Related  Product Forums


                     â†’ Flexera One



                      â†’ Snow Atlas



                      â†’ FlexNet Manager



                      â†’ Snow License Manager



                       â†’ App Broker


       Need help finding an answer?


        Ask a Question →


Loading
vCenter VMWare inventory doesn't work with Discovery and Inventory Rules