Loading
Could not create the Snow License Manager login. Error Message: This Login is the Owner of 139job(s). You must delete or reassign these job before the login can be dropped. The Server Principle "LicenseManagerUser" already exists.

Hi Team,

 

While installing the Snow License Manage, it is failed to create the the Database due to below error.

Could you please some one help us to fix this issue asap.

 

Could not create the Snow License Manager login. Error Message: This Login is the Owner of 139job(s). You must delete or reassign these job before the login can be dropped. 

The Server Principle "LicenseManagerUser" already exists.

 

 

image


  • Hi ManijKumar,

     

    I'd say the message is quite self-explanatory.

     

    You try to create a new SLM database in a SQL instance, where the LicenseManagerUser already exists as a login.

    The setup routine cannot delete and recreate the LicenseManagerUser, as this user owns all the Jobs releted to the Data Update Job (see Jobs or Job Acticity Monitor in the SQL Server Agent section in SQL Server Management Studio).

     

    You could run SnlowLicenseManager.dbo.JobRemove to remove the Jobs, them drop the Login for LicenseManagerUser, then retry the installation.

     

    Kind regards,

    Axel

     

    Expand Post
    • Hi Axel,

       

      Thanks for an update.

       

      I have tried as you suggested. but still i could facing the same issue.

       

      Is their any other option to fix this issue.

       

      I would expecting our input to fix the issue,

      Expand Post
      • Hi Manojkumar,

         

        no, there is no other option.

         

        I suggest to deleten the LicenseManagerUser manually in SQL Management Studio. To be able to do this, you will have to remove the jobs and usually reassign some db schemas, as LicenseManagerUser is by default also the owner of some schemas.

         

        Please be aware, that LicenseManagerUser can still be listed in the databases, including system databases master and msdb.

         

         

        Expand Post
      • Hi Axel,

         

        From SQL Management Studio, I have removed the Job by running the given query.

         

        If could possible, Can I have an steps to remove the username from remain table please

        Expand Post
      • Hi Axel,

         

        Thanks for your support and suggestion. 

         

        Now we are able to get install the SLM DB and it looks good

        Expand Post
  • Detlev Eufinger (Flexera Software)

    Hi manojkumar,

     

    unfortunately it doesn't look to me as if you have the appropriate knowledge about installing the slm.

    Please contact your internal DBA and let them clean it up..

     

    Or even better: Contact a trusted partner or the Snow Professional Service with your request for a new installation.

    I think that's the only way to get a properly running Snow Software environment.

    Expand Post

Related  Product Forums


                     → Flexera One



                      → Snow Atlas



                      → FlexNet Manager



                      → Snow License Manager



                       → App Broker


       Need help finding an answer?


        Ask a Question →


Loading
Could not create the Snow License Manager login. Error Message: This Login is the Owner of 139job(s). You must delete or reassign these job before the login can be dropped. The Server Principle "LicenseManagerUser" already exists.