Loading

ApplicationsPreferredMetric

Skip Feed
  1. Dear community Since several months we have been facing issues with the Data Update Job. Specifically the PVU part on our SPE platform is failing everyday with the following error: Cannot insert duplicate key in object dbo.#ApplicationsPreferredMetric

    Error message: "Cannot insert duplicate key in object 'dbo.#ApplicationsPreferredMetric"

    In more detail: "Violation of PRIMARY KEY constraint 'PK__#Applica__C93A4F797B02140B'. Cannot insert duplicate key in object 'dbo.#ApplicationsPreferredMetric'. The duplicate key value is (a822e956-93ef-452b-af99-ceca5742a95c)"

     

    Basically it looks like on our SPE platform there are 3 customers with the same PVU product installed. The stored procedure that is behind this, seems to try and insert that application key 3 times (for the 3 customers with that same products) in a table where the app key is the primary key. Causing a PRIMARY KEY constraint error of course.

     

    We have been getting nowhere with Snow support, hence I am looking at the power of the Snow Community to get input from customers with a similar issue and how they found a workaround for this?

     

     

    Regards

    Expand Post

    1 of 3
    • Mike Rossouw (Flexera Software)

      It looks like its a duplicate of the preferred metric registered against the specific application. Search for the application in question, edit and delete the duplicate metric. This should resolve it, if not log a support request.

End of Feed
1 Chatter Feed Items
ALL CONVERSATIONS
UNSOLVED
ARTICLES
1 Post

Related Topics

    Loading
    ApplicationsPreferredMetric | Flexera