Loading
License Check Fails When Checking Out

We are experiencing an issue where checking out a Catalog Item and enabling either License Check or Advanced License check causes App Broker to completely freeze and therefore fail the checkout processes. The connection to FNMS appears to be working just fine in every other area of App Broker. Any ideas why this might be occurring? Screenshot shows the view that freezes up when we try to check out. 


  • We have tried it during multiple different times of the day and it consistently happened so I don't think it's related to a reconciliation. This is on 2019R1. Actually looking at the FNMS Integration log did shed some more light on what the issue is related to - the log shows the message "The provided URI scheme 'http' is invalid; expected 'https'" in many places, which is an error I have run into before with this customer in the App Portal UI. The first time I ran into the error it was caused by a WebAPI.config file for FNMS that included entries for serviceURL that were http instead of https, so I changed the config file to use https instead and the problem was resolved. Now it appears that there may still be some parts of the configuration trying to use http that I will need to identify and fix.  

    Expand Post
    Selected as Best
  • CharlesW (Flexera Software)

    Is this always happening, or does this occur only during certain times of the day? I know that there is an issue in FNMS where it won't respond in a timely manner if the license check is performed during a reconcile.. FNMS engineering is working on this currently. What version of App Portal are you seeing this on? Do you see any exceptions/errors in FNMSintegration.log?
    • We have tried it during multiple different times of the day and it consistently happened so I don't think it's related to a reconciliation. This is on 2019R1. Actually looking at the FNMS Integration log did shed some more light on what the issue is related to - the log shows the message "The provided URI scheme 'http' is invalid; expected 'https'" in many places, which is an error I have run into before with this customer in the App Portal UI. The first time I ran into the error it was caused by a WebAPI.config file for FNMS that included entries for serviceURL that were http instead of https, so I changed the config file to use https instead and the problem was resolved. Now it appears that there may still be some parts of the configuration trying to use http that I will need to identify and fix.  

      Expand Post
      Selected as Best
      • jdempsey (Flexera Software)

        Strictly from an App Portal/FNMS integration perspective, here are places to look (assuming you're using the Flexera Service Gateway):

        1. The webapi.config has 3 instances of the FNMS URL that need to be updated.  Make sure you got all 3 of them.
        2. Launch FlexeraServiceGatewayHost and View Services to verify the URL's that are currently registered.  If not correct, check the webapi.config from 1 above and then rerun the registration tool.  Repeat this check to verify the newly registered service URLs.
        3. Within the App Portal admin UI, on the Flexera Integration tab, you should see (in small blue text directly below the FSG server name) the URL to the FNMS endpoint.  Make sure that is correct.  If incorrect, see 2 above.
        Expand Post

Related  Product Forums


                     → Flexera One



                      → Snow Atlas



                      → FlexNet Manager



                      → Snow License Manager



                       → App Broker


       Need help finding an answer?


        Ask a Question →


Loading
License Check Fails When Checking Out