Loading
Accidental Delete - Computers Not Removed From SQL DB

My colleague accidentally deleted existing machines from the web-frontend of SNOW when importing data as there was a tickbox that noted deleting exisiting data which they either ticked or did not tick to cause this. This aside, what we noticed was that once all 16,000 approx. computers disappeared from the frontend, a number of days went by (as I was on leave) and on my return I noticed that nothing had been deleted from the SQL database... please can anyone help explain how this could have failed to have been deleted of the SQL database as well?

Running: Version 9.3 Revision 01 Build 7118 SnowLicenseManager 


  • Hi, i think the best part is to open a support ticket so snow can help you with the repair. I would almost say that resetting the sequence number and re-doing DUJ should fix the problem. USE SnowLicenseManager UPDATE dbo.tblInventoryDatabase SET NewRowVersion = 0x0, NewSequenceNumber = 0; But please do that with the Snow Support :-) I keep my fingers crossed!
    • Thank you for the advice on that one, I have managed to delete all of the existing assets from the SQL DB and had to reset the DUJ and data is now following but I’m just not able to understand why it happened in the first place where computers can be deleted from the frontend but then they are not deleted from the SQL DB? Kind regards, Grant Taylor
      • Hi Grant,  There are a couple of things that could have happened. If you delete 1000 active computers from the License Manager web gui, they will be deleted from both the License manager DB and the Inventory DB within a day, at least if things work as they should.  However, if these 1000 machines are all active computers they will report in again after a day or two and will be re-registered in both databases, but the usage history is now gone and it will look like a brand new computer ini License Manager and Inventory server.  If this explanation is dismissed, it could be that you have an issue with the delete process between the two databases. There is a windows service that handles the delete process called SnowLicenseManagerInventoryService.  It needs to be started, and the service log must not contain errors.  You will find the logs in this location:  C:\Program Files\Snow Software\Logs\InventoryService Open the latest file and search for ERROR;. If there are constant error messages about connection issues, you should contact the technical support for further analysis.  / Martin 
        Expand Post
        • Thank you for the advice Martin, I'll certainly check-out the latter part as I believe what you have described is basically what happened. The only issue was that even though the 16,000 approx. machines were deleted, they were still in the SQL DB yet they couldn't sync back to the website frontend when 'Data Update Job' was run, as expected. Follow-up: I've just checked for this service and can only see it being present on our website/licence manager server (assuming this is normal) but not on the Inventory or SQL servers. The service is 'Running'. There are errors stating: 00:20:55,634 57 ERROR ConfigurationService; Pinged Resource: https://SERVERNAME01:443 With Error : An error occurred while sending the request. Details: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. 00:22:02,574 64 ERROR ComputerDeleteService; No valid API-endpoint found, aborting! 00:22:02,590 63 INFO UserDeleteService; No users to delete 00:22:02,637 64 INFO DeviceDeleteService; No devices to delete 06:20:56,977 57 ERROR ConfigurationService; Pinged Resource: https://SERVERNAME01:443 With Error : An error occurred while sending the request. Details: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. 06:22:03,267 66 INFO DeviceDeleteService; No devices to delete 06:22:03,282 66 ERROR ComputerDeleteService; No valid API-endpoint found, aborting! 06:22:03,282 67 INFO UserDeleteService; No users to delete   This type of error is happening daily, though on the dates that the deletions occurred, I can see any reference to any of them being requested to be deleted. I have now raised a case for this: CS0055746 Thank you everyone.
          Expand Post
          • Hi Grant,  I would recommend to check the table in Snow Inventory Database ->  inv.Server.Address I'm guessing that your SSL certificate was issued based on FQDN.  Please update the Address field by adding domain to the server name.  https://SERVERNAME01.DOMAIN.COM:443 Restart the service SnowLicenseManagerInventoryService and let us know if you are still getting errors in log.  I would also love to see the response from Snow Support - could you please share it with us?  Thanks, Dominik
            Expand Post
            • SOLUTION: Thanks Dominik for the advice, I forgot to follow-up on this to help others.   # The SSL certificate is a domain/wildcard-type (not sure on the technical name) for example *.domainsite.com so any prefix could be used with it.   Oddly enough, the solution was to edit the snowserver.config file which looked similar to this: </ConnectionString> <Server> <SiteName>AMAZINGSITE</SiteName> <IncomingFolder>C:\Program Files\Snow Software\Snow Inventory\Server\Incoming</IncomingFolder> <BaseAddress> *.domainsite.com* </BaseAddress> </Server>   Where the address for the inventory server was set to *.domainsite.com rather than it specifically pointing to the website, for example https://snowinventory.domainsite.com:443  such as this: </ConnectionString> <Server> <SiteName>AMAZINGSITE</SiteName> <IncomingFolder>C:\Program Files\Snow Software\Snow Inventory\Server\Incoming</IncomingFolder> <BaseAddress> https://snowinventory .domainsite.com:443 </BaseAddress> </Server> After this was altered, the PCs which were deleted from the web front end then started to be deleted from the inventory database. Originally the SNOW Inventory service log showed this: 18:21:14,464 47 ERROR ConfigurationService; Pinged Resource: https://SERVERNAME1:443 With Error : An error occurred while sending the request. Details: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. 18:22:23,557 83 INFO DeviceDeleteService; No devices to delete 18:22:23,604 83 INFO UserDeleteService; No users to delete 18:22:23,636 84 ERROR ComputerDeleteService; No valid API-endpoint found, aborting! Now the log shows this: 13:07:54,527 22 INFO ConfigurationService; Pinged Resource: https://snowinventory.domainsite.com:443 With Success 13:08:58,657 23 INFO DeviceDeleteService; No devices to delete 13:08:58,689 24 INFO UserDeleteService; No users to delete 13:08:58,704 23 INFO ComputerDeleteService; Sent: 16739|16751|16834|16830|16758|16855|16933|16926|16853|16975|16964|17031|17027|16937|17106|17087|17083|17140|22325|20658|19786|28546|31919|29239|27086|26968|33828|33872|34078|34053|34156|34144|34243|34344|34318|34424|34409|34390|34583|34674|34864|34862|34856|34847|34838|34820|34959 for deletion in Inventory Db with ID: 1 13:08:59,314 9 INFO ComputerDeleteService; Deleted: 47 computers from deletedList in SLM. Issue now resolved. 
              Expand Post
          • Ah, yes that is absolutely a reason for the failed delete routine.   It is correct that the service is only avaiable on the License Manager server. It is supposed to contact the Inventory Server API to forward the delete request, but as you can see it has an issue reaching that API,  and it seems to be related to the certificate trust.  I think support has seen this before, and should be able to provide a solution or a workaround.  / Martin 
            Expand Post

Related  Product Forums


                     â†’ Flexera One



                      â†’ Snow Atlas



                      â†’ FlexNet Manager



                      â†’ Snow License Manager



                       â†’ App Broker


       Need help finding an answer?


        Ask a Question →


Loading
Accidental Delete - Computers Not Removed From SQL DB