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Symptoms

Attempts to invoke ndtrack.exe on computers to gather inventory from computers with the FlexNet beacon component installed without specifying a path to the file may fail with a "file not found" type error.

A common symptom is to see logging like the following appearing in the agent’s C:\Windows\Temp\ManageSoft\schedule.log file:

[2/13/2022 6:05:21 PM (G, 0)] {1520} Execute “ndtrack -o InventoryType=Machine  -o UserInteractionLevel=Quiet”
[2/13/2022 6:05:21 PM (G, 0)] {1520} Execute “Failed to start <ndtrack> with error 2 (0x2), hInstApp 2: The system cannot find the file specified.”
[2/13/2022 6:05:21 PM (G, 0)] {1520} Execute “Failed to start <ndtrack>, verb <open>, flags (0x800440) with error 2 (0x2), hInstApp 2: The system cannot find the file specified.”
[2/13/2022 6:05:21 PM (G, 0)] {1520} Execute returned “File Not Found:ndtrack -o InventoryType=Machine  -o UserInteractionLevel=Quiet”. 

Cause

This occurs because the beacon installer incorrectly sets path details for the ndtrack.exe executable under the HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\App Paths\ndtrack.exe registry key.

Details

The beacon installer may incorrectly set the path to the ndtrack.exe executable under the HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\App Paths\ndtrack.exe registry key.

As a result, any attempts to invoke ndtrack.exe in a way that depends on these settings (such as invoking ndtrack.exe from a cmd shell window without specifying a path) will fail.

Workaround

Confirm the installation directory of the FlexNet beacon software component. This is commonly C:\Program Files (x86)\Flexera Software\Inventory Beacon.

Update the following registry entries under the key HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\App Paths\ndtrack.exe as follows (replacing all references to the installation directory with your directory if it is different):

  • (Default) = C:\Program Files (x86)\Flexera Software\Inventory Beacon\Tracker\ndtrack.exe
  • Path = C:\Program Files (x86)\Flexera Software\Inventory Beacon\Tracker\;C:\Program Files (x86)\Flexera Software\Inventory Beacon\Common

Fix details

This issue has been fixed by updating the beacon installer to use the correct installation path.

Fix status

This issue has been fixed in the following FlexNet Manager Suite releases: 2021 R1.4 / Mar 2022 (Cloud), 2022 R1 (On Premises)

Other information

Affected components: Component installers, Inventory, Inventory Beacon

Master issue ID: IOJ-2235433

Also known as: FNML-74857

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Version history
Last update:
‎Jul 27, 2022 02:33 AM
Updated by:
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