cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Symptoms:

After clearing all the requirements for XenDesktop discovery following the below KB article, sometimes still got the 'not discovered' error in the discovery.log
https://community.flexera.com/t5/FlexNet-Manager-Knowledge-Base/XenDesktop-discovery-Installation-and-access-requirements/ta-p/6103

Diagnosis:

In the discovery.log, you may see there are messages with different machine names, e.g.

2020-07-02 14:36:03,180 [iscoveryActionExecuter|IPScan] [INFO ] Device 'rpawipv0001' is in scope: AU_XENDESKTOP_PROD_NAWWIPA0100
...
2020-07-02 14:36:03,227 [.DiscoveryTaskExecutor|PropertyDisco] [INFO ] Performing Xen Desktop discovery for device 'NAWWIPA0100'

In this case, there is possibly a DNS issue, please confirm the correct machine name and make sure that the hostname is being resolved correctly from the beacon (e.g. both the IP & computer name can be pinged)

Solution:

The beacon discovers a Citrix Delivery Controller by interrogating WMI remotely on the target server. In order to test if this works manually, you can run the following in a PowerShell window on the beacon:

Get-WmiObject Win32_Service -Filter "Name = 'CitrixBrokerService'" -ComputerName "NameHere"

Try this with both the IP and the computer name and see what the results are. If there is some error then you can troubleshoot a problem with accessing WMI remotely - there is some useful information here
https://docs.microsoft.com/en-us/windows/win32/wmisdk/troubleshooting-a-remote-wmi-connection

Was this article helpful? Yes No
100% helpful (2/2)
Version history
Last update:
‎Dec 20, 2020 08:51 PM
Updated by: