Uploader log reports a HTTP error 409 on Inventory Beacon

Uploader log reports a HTTP error 409 on Inventory Beacon

Summary

The Inventory Beacon?s ?Upload Flexera logs and inventories? scheduled task is failing with an 0x1 code.

Symptoms

The ?Upload Flexera logs and inventories? scheduled task is failing with an 0x1 code:
User-added image

The uploader.log, located in the "Temp\Managosoft" folder for the user that runs the above task will contain the inventory is failing to upload and a HTTP error 409 is occurring:
Error 0xE0500199: HTTP error 409
Error 0xE0500452: Failed to write remote file /ManageSoftRL/UsageData/serv003 at 5483882832.mmi.gz
Error 0xE069009A: Error transferring data (Network error?)
ERROR: Local PUT failed
Ignoring failover locations for upload on an inventory beacon
WARNING: FlexNet Manager Platform has failed to upload a file to all configured upload servers; aborting attempt to upload these file(s)
Uploading finished

Cause

The beacon is designed to work with Basic Authentication. If this is not configured this error may occur.

Resolution

Configure the ManageSoftRL node in IIS on the FNMP server to only use ?Basic Authentication?:
User-added image

Once this has been done, run iisreset to restart the iis services.

Additional Information

On FNMS 2015 ONLY once you have set basic authentication, if you still get 409 errors you may be experiencing a known issue where the resolvers have difficulty processing discovery files into the database.

A patch was created to improve the way discovery files (and others) are resolved into the database, to apply it follow the instructions below:
  1. Stop IIS while carrying out these steps and then start it back up again afterwards.
  2. Take a backup of all Flexera..dll and ManageSoft..dll files in the C:\Program Files (x86)\Flexera Software\FlexNet Manager Platform\Importers\bin location into a new folder outside the bin folder
  3. Copy the DLLs from the attached "http_409.zip" into the above location
  4. Make this further change in Importers\web.config
    • <add key="WorkloadMaxLimit-discovery" value="25" />
  5. Update the "InventoryDatabaseConnectionString" registry key to have a "Max Pool Size" of a 1000, the key is located in the following hive with an example below:
  • Hive: Managesoft Corp > Managesoft >Reporter >CurrentVersion.
  • Example Key: Driver={SQL Server};Server=<ServerName>;database=<DatabaseName>;Trusted_Connection;Max Pool Size=1000

This issue has been permantly resolved in FNMS 2015 R2 SP1, it is recommended to upgrade to this version or higher.
Labels (1)
Was this article helpful? Yes No
No ratings
Version history
Last update:
‎Jan 30, 2019 02:39 AM
Updated by: