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Symptoms:

When starting the cognos service using IBM Cognos configuration, there may be a message in the IBM Cognos Configuration, or in one of the cognos logs ‘cogaudit.log’, similar to the one below. The message seems to indicate that ‘ServerA.xxx.com’ is the active Content Manager URL. However, in the specific scenario discussed in this article, ServerA is not the correct Cognos server and thus the active content manager should point to a different correct server.

CM-SYS-5160 Content Manager is running in standby mode. The active Content Manager URL is http://ServerA.xxx.com:9300/p2pd/servlet.

Diagnosis:

The CMCAPACITY table in the ContentStore database stores URIs of both active & standby content managers (CMs). The active content manager contains the Usage value of 4 in this table. When the Cognos service is running, the CMPATH field contains the active content manager’s URI, but when the service is stopped, the value of this field is removed.

The above symptom occurred when the CMCAPACITY table of the Contentstore database contained the incorrect server (ServerA) URI with Usage value of 4 in the CMPATH column. This can happen if there are two separate cognos environments inadvertently using the same ContentStore database. The impact of this issue is that user from FNMS webui>Reports tab is not able to access Analytics.

Solution:

The ContentStore database should not be shared between two cognos environments. In the above case, the IBM Cognos service was stopped and then disabled in the incorrect Cognos server ‘ServerA’ environment.

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Last update:
‎Jun 18, 2020 12:44 AM
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