Summary
Package import in Cognos Analytics fails to load.
Symptoms
When Report Designer/Cognos Analytics is installed on a different Server than the FNMP/FNMS Application Server, the following error occurs when importing a report packages. However, the dispatcher is running on the displayed URL.
A problem occurred
FlexNet Manager Platform was unable to log in to the Cognos server, Please make sure that the Dispatcher is up and running at http://CognosServerName:9300/p2pd/servlet/dispatch and that it is configured correctly.
Details:
---Problem---
(s0m0): FlexNet Manager Platform was unable to log in to the Cognos server. Please make sure that the Dispatcher is up and running at http://CognosServer:9300/p2pd/servlet/dispatch and that it is configured correctly.
---System exception---
FlexNet Manager Platform was unable to log in to the Cognos server. Please make sure that the Dispatcher is up and running at http://CognosServer:9300/p2pd/servlet/dispatch and that it is configured correctly.
---Stack trace---
ManageSoft.Compliance.ComplianceException: FlexNet Manager Platform was unable to log in to the Cognos server. Please make sure that the Dispatcher is up and running at http://CognosServer:9300/p2pd/servlet/dispatch and that it is configured correctly. ---> System.Web.Services.Protocols.SoapException: CM-REQ-4342 An error occurred with the client.
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at cognosdotnet_2_0.contentManagerService1.logon(xmlEncodedXML credentials, searchPathSingleObject[] roles)
at ManageSoft.Common.Presentation.MMC.CognosConnection.Login()
--- End of inner exception stack trace ---
at ManageSoft.Common.Presentation.MMC.CognosConnection.Login()
at ManageSoft.Common.Presentation.MMC.CognosConnection.ImportPackage()
at ManageSoft.Common.Presentation.MMC.CompliancePropertiesDlg.<m_PublishPCognosPackageButton_Click>b__0()
Cause
In FlexNet Manager Suite, a possible cause is that the Service Account running the IBM Cognos service and running the Package Importer Utility does not have the proper role, or has an Analytic User role as well.
In FlexNet Manager Platform 9.2.3 and below, make sure that the user in BusinessReportingAuthentication's Application Pool in IIS is set with a user with the domain name, not just a user. You can try this in FlexNet Manager Suite as well if the above was not successful and you receive the same error.
Resolution
Make sure in FlexNet Manager Suite that the following role is assigned to the Service account running the Package Importer Utility and the IBM Cognos service "Business Reporting Portal Admin" and no other Analytic roles assigned.
Another option if the above was not successful and in FlexNet Manager Platform is specifying the user account with a domain like "Domain\svc-flexnet" in the IIS Application Pool.