Summary
QE-DEF-0285 'The logon failed' error when generating a COGNOS Report Designer report.
Symptoms
When attempting to run a Report Designer report you may encounter the following error in the GUI:
QE-DEF-0285 'The logon failed'
Clicking the
details button reveals the following:
QE-DEF-0323 The DSN(ODBC)/ServiceName is invalid. Either the DSN is missing or the host is inaccessible.
RQP-DEF-0068 Unable to connect to at least one database during a multi-database attach to 1 database(s) in: FNMReportDS
UDA-SQL-0031 Unable to access the "FNMReportDS" database.
UDA-SQL-0532 Data Source is not accessible: "<DatabaseName\Instance>".
UDA-SQL-0564 [Microsoft OLE DB Provider for SQL Server][DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied. (SQLSTATE=08001, SQLERRORCODE=17)
You may notice that the database instance name is still pointing to an old instance.
The error may also still be present after changing the cognos configuration by running C:\Program Files (x86)\Report Designer\Configure_Flexnet_Report_Designer.exe (this is the default location, this may differ for your environment).
A re-install of Cognos Report Designer using the correct details still displays the same error.
Cause
This may have been caused by a misconfiguration of the database instance during the initial Cognos installation.
Resolution
In the Report Designer interface navigate to Launch> IBM Cognos administration> configuration tab> data source connections > FNMReportDS> more > set properties> connection tab> connection string
Please ensure that the connection string is referencing the correct database instance under
Data Source =.
Example connection string:
^User ID:^?Password:;LOCAL;OL;DBInfo_Type=MS;Provider=SQLOLEDB;User ID=%s;Password=%s;Data Source=localhost,1433;Provider_String=Initial Catalog=flexnet_reporting_15.5;@COLSEQ=