Summary
OLE DB provider for Oracle is installed but "OLE DB provider for Oracle is not installed" message is logged in the action status.
Symptoms
Oracle database inventory requires 32 bit
OLE DB Provider for Oracle on the beacon server.
OLE DB Provider for Oracle is installed but the
Oracle database inventory in the
action status of the
Discovery Device Properties page shows like the following messages in the
Details of
Last Failure.
Error 0x0800a0e7a "Provider cannot be found. It may not be properly installed." occurred while attempting to access "ADODB.connection".
Error 0x0800a0e7a "Provider cannot be found. It may not be properly installed." occurred while attempting to access "ADODB.connection".
OLE DB provider for Oracle is not installed
Cause
OLE DB Provider for Oracle was installed after Inventory Beacon installation and
Flexera Inventory Beacon Engine service has not restarted after
OLE DB Provider for Oracle installation.
Resolution
- Stop Flexera Inventory Beacon Engine service.
- Restart Flexera Inventory Beacon Engine service.
- Don't use the restart button or menu, it needs to stop the running Flexera Inventory Beacon Engine service and then restart it.
Additional Information
If the same error occurs after restarting
Flexera Inventory Beacon Engine service, there is a possibility that Oracle installer failed to register
OLE DB Provider for Oracle.Run like the following commands and then restart
Flexera Inventory Beacon Engine service.
- Open a Command prompt in administrator mode
- cd %ORACLE_HOME%\bin
Example: cd \oracle\product\11.2.0\client_1\BIN
- Register the dll of OLE DB Provider for Oracle
Example: Oracle 11gR2
32 bit environment
c:\Windows\system32\regsvr32.exe OraOLEDB11.dll
64 bit environment
c:\Windows\SysWOW64\regsvr32.exe OraOLEDB11.dll
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