Summary
If when accessing the FNMS Web UI you get error "HTTP Error 503. The service is unavailable" then this article provides some suggestions on the common causes
Symptoms
This article covers the scenario when accessing the Web UI you see http error 503 : The service is unavailable, similar to the screenshot below:
Cause
This error appears when the web application is unavailable, this means that the site is up and running but the underlying application pools have an issue. The first place to check is the Application Pools node in IIS, see this example screenshot:
As you can see above, the "Flexnet Manager Suite" application pool is in a stopped state which is what is causing the http error 503.
Resolution
In order to resolve this you should start the application pool and if it fails to start you need to look at Windows event logs to see what errors are shown.
This is most common when a specific account is used as the application pool identity (common configuration) as you can see in the screenshot. In most cases when this error occurs it is because the username / password is incorrect and so the event log will show failed logon attempts.
In this case, simply update the password for the Identity account in the Application pool advanced settings and restart the application pool.
Additional Information
While the identity account is the most common cause of the application pool being stopped, it is not the only cause. If updating the password doesn't work, try and restart the application pool and investigate Windows event logs to find specific details on why it failed to start.