Summary
This article will describe a product internal issue of FNMS product version 2016+ with a workaround approach. Customer may receive unexpected error red message while viewing 'All Inventory' page.
Symptoms
This article will describe a product internal issue of FNMS product version 2016+ with a workaround approach. Customer may receive unexpected error red message while viewing 'All Inventory' page.
https://www.flexnetmanager.com/Suite/ComputerProperties/List/All
The specific red error bar saying: An error has occurred while retrieving information; you may need to refresh the page.'
The specific error in the webui.log:
"All Inventory page loading error - ASP._Page_Views_ComputerProperties_Templates_Display_AssetLink_cshtml.Execute()"
Cause
This a data related product defect has been identified on version FNMS 2017, potential it will hit prior version as well.
Combining with the following conditions , you may hit the error:
1. You have Virtual Machine & VIrtual Host in your inventory list
2. You have added 'Linked Asset' in the grid view from column chooser
3. You have selected a large number of row per page value eg: 1000
Red Error may occur while your UI with above setting.
Resolution
A defect has been reported on FNMS 2017 version via FNMS-45178 for further fixing.
Workaround
1. Go to affected page ,but added reset in the URL suffix as below to have a force reset all grid back to default value
https://www.flexnetmanager.com/Suite/ComputerProperties/List/All?reset
2. Then go back to "Discovery & Inventory" --> "All Inventory" page , where the grid is now showing default columns
3. Select "Host" column from Column chooser First
4. Select "Linked Asset" column from column chooser as second
PS. "Linked Asset" has to be added into grid after "Host" column being added. If opposite , you may hit the error.
Additional Information
If the above workaround doesn't help ,
For On Premise FNMS customer , please provide with the WEBUI.log with exactly error UID from the UI page
For On Demand FNMS customer , please provide with the UID from UI page
send the error with description to
Flexera Technical Support for further assistance.