Showing results for 
Show  only  | Search instead for 
Did you mean: 

When importing large numbers in Business Adapter Studio from an Excel spreadsheet, they may show in scientific notation (for example, 1.01578e+010) in the FlexNet Manager Suite UI. This commonly occurs for purchase order numbers or serial numbers that you may not want expressed in scientific notation. Large values become expressed as scientific notation due to the behavior of Microsoft's OLE DB driver, which reads the source data.

 Change the cell data type

To correct this, you can use a schema.ini file to specify the data type for any cells you don't want to show in scientific notation.

1. Change the cell category in the Excel spreadsheet cell to text.

Right-click on the cell(s), choose Format cells, select Text, then select OK.

         format cells.png
2. In the data source view, enable the Read "Intermixed" data columns as text option under the Excel File Properties section.


3. Use a schema.ini file to specify the data type when importing. The schema.ini file will be consumed in the process.

NOTE: See Microsoft's documentation for help with Schema.ini Files (Text File Driver).

Was this article helpful? Yes No
67% helpful (2/3)
Version history
Last update:
‎Dec 28, 2022 12:06 PM
Updated by: