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Summary

All agents installed are not able to refresh their policy

Symptoms

From a deployed beacon, the following error is found in the BeaconISS log file :

2018-02-15 08:29:48,856 [mmon.BeaconPolicyCache] [ERROR] Could not load policy file from disk.
System.IO.IOException: The process cannot access the file 'C:\ProgramData\Flexera Software\Beacon\BeaconPolicy.xml' because it is being used by another process.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
at Flexera.Beacon.Common.BeaconPolicyCache.LoadBeaconPolicyFromDisk()

As consequence, new agents are not reporting to the App Server.

Cause

If you get the System.IO.IOException: The file exists error, it's probably because your C:/Windows/Temp folder is absolutely full with temporary files. In fact, if you have more than 65535 files in your temp folder, the method GetTempFileName will throw this error.

Resolution

To resolve this, just remove all temporary files in C:/Windows/Temp. It might take some time, but it will solve the problem.

After clearing files from c:\windows\temp and restarting the beacon engine service, then agents should be able to update their policy.
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Version history
Last update:
‎Nov 15, 2018 05:04 PM
Updated by: