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Summary

An "An unexpected error occurred while reading the license" error is displayed when importing a new license into FlexNet Manager Suite.

Symptoms

When import a new license using the Managesoft.Activation.Wizard.exe the following error message is displayed and the license is not imported.

Screenshot:

User-added image

Error Text:

---Problem---

(s0m0): There was an error importing the license. Please contact Flexera Software support for assistance.

---System exception---

An unexpected error occurred while reading the license

---Source---

Flexera.LicenseManagement

---Stack trace---

Flexera.LicenseManagement.FlexeraLicenseReadException: An unexpected error occurred while reading the license ---> FlxDotNetClient.PublicLicensingException: A licensing error was encountered: Data version is not supported.: [1,4,5,0[7000002F,0,190751]]

at #wb.#ie.#ee(Type declaringType)

at #wb.#ie.#fe(#le function, Object caller)

at #wb.#9c.#Lb(Byte[] buffer, String name, Boolean diagnostic)

at #wb.#Zc.AddBufferLicenseSource(Byte[] buffer, String name)

at #wb.#Ld.AddBufferLicenseSource(Byte[] buffer, String name)

at Flexera.LicenseManagement.Impl.LicenseReader.LoadLicense(ILicensing licensing, Byte[] rawLicense)

--- End of inner exception stack trace ---

at Flexera.LicenseManagement.Impl.LicenseReader.LoadLicense(ILicensing licensing, Byte[] rawLicense)

at Flexera.LicenseManagement.Impl.LicenseReader.ReadLicense(Byte[] rawLicense, Boolean allowValueOnExpiredTerms)

at ManageSoft.Activation.ActivationWiz.ProcessLicenseFull(String p_LicenseFileLocation)

at ManageSoft.Activation.NoticePage.m_ImportLicenseBtn_Click(Object sender, EventArgs e)


Cause

This error message is caused by an incomplete or corrupt license.


Resolution

To ensure there is no corruption in the license file, the license can be re-downloaded from the product and license centre and re-imported.


Additional Information

If the error message is still present after re-importing the newly downloaded license file please submit the license file along with the full details of the error message to Flexera Support for review.

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Version history
Last update:
‎May 05, 2018 02:06 AM
Updated by: