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Summary

How to fix 100% CPU usage for FlexNet Agent v4.x

Symptoms

We have seen instances where customers have reported their CPU usage on machines with the FlexNet Agent (v4.x) installed increased to 100% after the startup of the Agent and does not return to a normal level until the Agent is stopped.

Why is this and can it be fixed at all?


Cause

The reason for this seems to be due to the way that denial and usage data is being processed.

This can be switched off in the FlexNet Agent by using the below line in the FlexNet Agent site.properties file. This can be found in the <install dir>/config directory of the Agent installation.


Resolution

The test to carry out is:

  • Stop the FlexNet Agent
  • Add the below line to the site.properties file:
    flexnet.denial.service=off
  • Run the 'flexnet site make' command on the Agent
  • Restart the Agent

The above test should make the CPU Usage return to a 'normal' level.


Additional Information

The only side-effect of doing this is that we would not get the 'real time' denial data in the Operational Dashboard.

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Version history
Last update:
‎Aug 29, 2012 04:15 AM
Updated by: