EHacking
Frequent contributor

"Usage agent is configured not to run on this machine" message on Mac.

Jump to solution

I have successfully installed the new Flexera agent v.14 on a Mac. When I look in the usageagent.log file I see this message. How do I configure this to turn on the Usage Agent? I don't see anything in any documentation. Here's the full log.

[Wed Nov 20 07:42:12 2019 (G, 0)] {116} Usage agent started
[Wed Nov 20 07:42:12 2019 (G, 0)] {116} mgsusageag: No supported /proc found, using ps(1)
[Wed Nov 20 07:42:12 2019 (G, 0)] {116} Entering low priority mode due to LowProfile preference
[Wed Nov 20 07:42:12 2019 (G, 0)] {116} Usage agent is configured not to run on this machine

Erick Hacking, CSAM, CHAMP
IT Software Asset Manager, Lead Sr.
2 Solutions

Accepted Solutions
mag00_75
Frequent contributor

Re: "Usage agent is configured not to run on this machine" message on Mac.

Jump to solution

We have resolved the issue with a post-installation script

#!/bin/bash

CURRENT_USER=`/bin/ls -l /dev/console | /usr/bin/awk '{ print $3 }'`

/bin/cat <<EOF > /var/tmp/tempconfig.ini

[ManageSoft\Usage Agent\CurrentVersion]

Disabled=False

StartupDelay=600

Lowprofile=True

UploadPeriod=14400
SessionBackupPeriod=1800

[ManageSoft\Tracker\CurrentVersion]

Lowprofile=True

EOF

 /opt/managesoft/bin/mgsconfig -i /var/tmp/tempconfig.ini

View solution in original post

mag00_75
Frequent contributor

Re: "Usage agent is configured not to run on this machine" message on Mac.

Jump to solution

@EHacking 

Did you succeed in creating the /var/tmp/tempconfig.ini? 

When running the  /opt/managesoft/bin/mgsconfig -i /var/tmp/tempconfig.ini

It will basically update the runtime configuration file, /var/opt/managesoft/etc/config.ini

if you open up config.ini then you will notice if your settings was applied, probably you need to restart the usage service or do the Windows way and restart the computer.

View solution in original post

0 Kudos
5 Replies
mag00_75
Frequent contributor

Re: "Usage agent is configured not to run on this machine" message on Mac.

Jump to solution

We have resolved the issue with a post-installation script

#!/bin/bash

CURRENT_USER=`/bin/ls -l /dev/console | /usr/bin/awk '{ print $3 }'`

/bin/cat <<EOF > /var/tmp/tempconfig.ini

[ManageSoft\Usage Agent\CurrentVersion]

Disabled=False

StartupDelay=600

Lowprofile=True

UploadPeriod=14400
SessionBackupPeriod=1800

[ManageSoft\Tracker\CurrentVersion]

Lowprofile=True

EOF

 /opt/managesoft/bin/mgsconfig -i /var/tmp/tempconfig.ini

View solution in original post

ChrisG
Community Manager Community Manager
Community Manager

Re: "Usage agent is configured not to run on this machine" message on Mac.

Jump to solution

See the following sources for guidance here:

(Anything expressed here is my own view and not necessarily that of my employer, Flexera. If my reply helped, give me a kudos. If it solves a question you have raised, please click "ACCEPT AS SOLUTION".)
EHacking
Frequent contributor

Re: "Usage agent is configured not to run on this machine" message on Mac.

Jump to solution
Didn't work. I'm not a Mac expert, and so I don't know why it didn't work. Is there any way to see why it didn't work?
Erick Hacking, CSAM, CHAMP
IT Software Asset Manager, Lead Sr.
0 Kudos
mag00_75
Frequent contributor

Re: "Usage agent is configured not to run on this machine" message on Mac.

Jump to solution

@EHacking 

Did you succeed in creating the /var/tmp/tempconfig.ini? 

When running the  /opt/managesoft/bin/mgsconfig -i /var/tmp/tempconfig.ini

It will basically update the runtime configuration file, /var/opt/managesoft/etc/config.ini

if you open up config.ini then you will notice if your settings was applied, probably you need to restart the usage service or do the Windows way and restart the computer.

View solution in original post

0 Kudos