Highlighted
Frequent contributor

could not upload inventory

Jump to solution

Hi all,

I attached to this post an error we have seen today for the first time. It doesn't look to be the usual privilege problem, instead it looks the beacon has problems in uploading the result of the inventory completed. Did someone of you have seen this before.

To give a context, we are performing a zero footprint inventory and the target here is a windows server.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Frequent contributor

Re: could not upload inventory

Jump to solution
We were adviced of changing the attribute "network name" in C:\Program Files (x86)\Flexera Software\Inventory Beacon\DotNet\conf of the Beacon placing there the IP of the beacon server. We will run today a test to see if it worked.

View solution in original post

0 Kudos
7 Replies
Highlighted
Community Manager Community Manager
Community Manager

Re: could not upload inventory

Jump to solution

The output does likely suggest some sort of problem with uploading. To get further specific details, check out the tracker.log file on the target device (IP address 10.21.72.29) which will likely contain more information about exactly what failed.

(Anything expressed here is my own view and not necessarily that of my employer, Flexera. If my reply answers a question you have raised, please click "ACCEPT AS SOLUTION".)
Highlighted
Frequent contributor

Re: could not upload inventory

Jump to solution

Thanks Chris, the customer sent me back the tracker.log.

I've read it and problem looks to begin here

 

[Wed Mar 25 19:07:46 2020 (G, 0)] {31016} Connecting to upload location 'http://dr3flex1/ManageSoftRL/Inventories/'
[Wed Mar 25 19:07:46 2020 (G, 0)] {31016} Upload username is ''
[Wed Mar 25 19:07:46 2020 (G, 0)] {31016} Upload proxy is ''
[Wed Mar 25 19:07:46 2020 (G, 0)] {31016} Uploading file 'flexera on rmbssas4 at 20200325T190647 for Machine (Full).ndi.gz' to 'http://dr3flex1/ManageSoftRL/Inventories/'
[Wed Mar 25 19:07:46 2020 (N, 0)] {31016} Error 0xE0500005: Host name lookup failed
[Wed Mar 25 19:07:46 2020 (N, 0)] {31016} Error 0xE050044D: Failed to create remote directory /ManageSoftRL
[Wed Mar 25 19:07:46 2020 (N, 0)] {31016} Error 0xE0690099: Specified remote directory is invalid, or could not be created
[Wed Mar 25 19:07:46 2020 (G, 0)] {31016} ERROR: Remote directory is invalid
[Wed Mar 25 19:07:46 2020 (G, 0)] {31016} Upload failed due to a client connection issue.  This server will not be retried during this upload session.
[Wed Mar 25 19:07:46 2020 (G, 0)] {31016} WARNING: FlexNet Manager Platform has failed to upload a file to all configured upload servers; aborting attempt to upload these file(s)
[Wed Mar 25 19:07:46 2020 (G, 0)] {31016} Uploading finished
[Wed Mar 25 19:07:46 2020 (G, 0)] {31016} ************************************************************
[Wed Mar 25 19:07:46 2020 (G, 0)] {31016} Unable to upload inventory file(s)
[Wed Mar 25 19:07:46 2020 (U, 0)] {31016} ERROR: Error (s189m263)
[Wed Mar 25 19:07:46 2020 (U, 0)] {31016} ----------------
[Wed Mar 25 19:07:46 2020 (U, 0)] {31016} FlexNet Manager Platform could not upload the inventory.

So it looks for me that the target cannot resolve hostname of the beacon, so it is not in DNS. Could it be a right answer?

I have also that ndtrack exited with error code 7 but I don't know the meaning

Thanks for the support

0 Kudos
Highlighted
Flexera
Flexera

Re: could not upload inventory

Jump to solution

Hi @marcog 

It appears that it might be a DNS issue, try changing the for upload address to use the FQDN to see if that resolves it. 

Many Thanks,

Matt 

If you find my answer useful please give kudos, if my answer solves your issue, please make sure to mark as solution
0 Kudos
Highlighted
Frequent contributor

Re: could not upload inventory

Jump to solution
Thanks for the answer, is there a place where I can configure the address differently? I can't see it anywhere.
0 Kudos