cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

When I am clicking on Open with report studio option. It is giving me attached error.

When I am clicking on Open with report studio option. It is giving me attached error. We are using FlexNet Manager for Engineering Applications 2016 R2. In earlier version, were getting another screen. Check that attachment as well.
0 Kudos

This thread has been automatically locked due to inactivity.

To continue the discussion, please start a new thread.

9 Replies

Hi Ranjanp,

Cognos uses .lck files as semaphores to prevent separate processes accessing and updating content/config files etc - the .lck file typically is just a text file with the processid (or some other flag) in it but it doesn't store anything that is not recoverable.    I couldn't say for certain, but I would guess that somewhere a process has crashed and you now have a new process that is clashing with the .lck file referenced.

My suggestion would be to:

  • Exit all Cognos UI's/studio's saving any relevant content.
  • Shut down the IBM Cognos service
  • Navigate to the the directory shown  in your error message (...\analytics\data\cqe\RTModels) and look for/delete the .LCK files.  It should be safe to remove all of them, but feel free to keep copies if you are extra cautious.
  • Restart the IBM Cognos service
  • Log back into FNMEA/Cognos and try again

-Murray

 

Hi, I have tried the below steps, but we cannot see any data on the screen. Please check attached. Expected screen and data is also attached. Regards, Ranjan
0 Kudos

@RANJANP  I would recommend opening a support case on this...

0 Kudos

Hi Ranjan,

Your screenshot showing "expected output" looks like the report is a "Query Studio" report, but the 2nd screens look like it's opened up in "Report Studio".    That doesn't really matter as Report Studio should be able to open and run reports developed in Query Studio, but I'm just wondering if you are getting confused between the two.

Can you try:

a) Do what you did to get to the latest second screenshot and then "Execute" the report (via Run menu or hit the play button in the toolbar).      The user experience in Report Studio is different from Query Studio, so the output may be a little different than what you expect, but you should see the same data and not receive any errors.

b) Go back to the start and in the list of reports seen in Cognos Connection explore the options to open the report in different studios (Query vs Report).    I don't have a Cognos 10 environment in front me so can't remember for sure, but I think you can Right click on the report name and choose from a set of options.

regards,
Murray

 

0 Kudos

Hi, Actually my concern is that only. I am not getting Query studio option there. So I tried Report studio. In earlier case, we used to change the date range and generate the data for verification. But in new case that option we are not getting. Regards, Ranjan
0 Kudos

So after you load the report into Report Studio ( which is the last screenshot you sent ) what happens when you go ahead and execute/Run the report? 

If you are still getting an error at that point that is the same as what you have already referred to you might be best advised to go ahead and raise a support incident with Flexera (for our benefit though pls send in any further screenshots here that include new details).

good luck
Murray

0 Kudos

Hi Murry,

Actually I tried to raise support ticket, but I am not getting option from where I can raise the same. Can you please provide any link, mail id?

 

Regards,

Ranjan

 

0 Kudos

@RANJANP  Don't you see the 'Get Support' -> 'Open new case' from the top menu in the community? If not you can email support (support@flexera.com) or call support:

Capture.PNG

0 Kudos

Hi! @RANJANP  - I've updated your account. Can you sign out and sign back in and try accessing the case portal? Many thanks! 

If you appreciate my efforts, please give me a kudo
Accept as solution to help others find it faster.
0 Kudos