Showing results for 
Show  only  | Search instead for 
Did you mean: 

Trying to Extend Active Directory Import Timeout Value But It Doesn't Seem to Have an Effect

Hi all ...

I'm running into the Active Directory import issue described here.

I have repeatedly tried to create the CommandTimeout registry entry and have adjusted the timeout setting, but after I create it and try to run the mgsimport command locally (so I can see the errors, which I can), it still times out after an hour.

Have I created the registry entry correctly?  Here's exactly what it looks like:


Here's the command I am running to try and perform the import manually:

mgsimport -t activedirectory -e c:\temp\myfile.actdir.gz

Here's the ending output where it times out after an hour:

File c:\temp\myfile.actdir.gz: Unexpected exception in importer
File saved to c:\temp\BadLogs\failure
All tasks are complete
Finished importing 1 files in 3640.3s

C:\Program Files (x86)\Flexera Software\FlexNet Manager Platform\Importers\bin>

What am I doing incorrectly? I defined CommandTimeout as a string value; should it be something else?



(5) Replies


It's difficult for forum members to provide guidance on environment specific issues, you may be better off contacting Flexera Support.

However, maybe you're running into other timeout settings, e.g., did you run a SQL Profiler during the process?


The decimal value should be of type REG_DWORD.

I tried changing the type to REG_DWORD but the AD import is still failing at an hour.  I'll open a support ticket.



In the first screen shot it seems your changing the Compliance CommandTimeout, according to documentation FlexNet Manager Suite Online Help - Registry Keys for Inventory Beacon ( you have to set the timeouts for an Active Directory import under  [Registry]\ActiveDirectoryImporter\CurrentVersion

Did you try this already?

I did not try this because the settings you linked to refer to the inventory beacon, but the issue is occurring during the reconciliation process on the FNMS server.