Highlighted
Occasional contributor

Issue while configuring inventory server

Jump to solution

Hello,

While running config.ps1 on inventory server to update fnms to 2019R2, after entering the credentials it gets stuck on below command:

Checking to see if there is a pending deployment... Found pending deployment (D:\ProgramData\Flexera Software\Warehouse\Staging\LockFile), waiting 60 seconds... 

Screenshot attached.

Any leads would be appreciated.

Regards,

Nidhi Kamat

1 Solution

Accepted Solutions
Highlighted
Occasional contributor

Re: Issue while configuring inventory server

Jump to solution

Hello Markward,

I moved the FNMS folder out of the other FNMS2019R2 folder and placed it directly in C:/tmp. Then the issue got resolved.

Thank you for the help.

Regards,

Nidhi Kamat

View solution in original post

4 Replies
Highlighted
Rising star

Re: Issue while configuring inventory server

Jump to solution

Hi,

There is a lock file in the mentioned folder. It is put there to prevent multiple instances of the config script running at the same time.

When the configuration does not finishing correctly, the lockfile is sometimes not removed. Just remove it manually and re-run the script.

Best regards,

Markward

Softline Group is Europe's leading independent expert in Software Asset Management.
Tags (1)
Highlighted
Occasional contributor

Re: Issue while configuring inventory server

Jump to solution
Hi Markward,

Thank you for the valuable input. Yes, there is a lockfile in the mentioned folder. But the file mentions that the deployment on the current (inventory which I am trying to configure) server is started, which is actually true. And I remove the file manually and run the config.ps1 I get the below error:
Could not find a part of the path." ---> System.IO.DirectoryNotFoundException: Could not find a part of
the path.
Below is the entire error message:
ExecuteCustomScripts : System.Management.Automation.MethodInvocationException: Exception calling "ExtractAll" with "2"
argument(s): "Could not find a part of the path." ---> System.IO.DirectoryNotFoundException: Could not find a part of
the path.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.File.InternalMove(String sourceFileName, String destFileName, Boolean checkHost)
at Ionic.Zip.ZipEntry.InternalExtract(String baseDir, Stream outstream, String password)
at Ionic.Zip.ZipFile._InternalExtractAll(String path, Boolean overrideExtractExistingProperty)
at CallSite.Target(Closure , CallSite , Object , Object , Object )
--- End of inner exception stack trace ---
at System.Management.Automation.ExceptionHandlingOps.CheckActionPreference(FunctionContext funcContext, Exception
exception)
at System.Management.Automation.Interpreter.ActionCallInstruction`2.Run(InterpretedFrame frame)
at System.Management.Automation.Interpreter.EnterTryCatchFinallyInstruction.Run(InterpretedFrame frame)
at System.Management.Automation.Interpreter.EnterTryCatchFinallyInstruction.Run(InterpretedFrame frame)
at System.Management.Automation.Interpreter.Interpreter.Run(InterpretedFrame frame)
at System.Management.Automation.Interpreter.LightLambda.RunVoid1[T0](T0 arg0)
at System.Management.Automation.PSScriptCmdlet.RunClause(Action`1 clause, Object dollarUnderbar, Object
inputToProcess)
at System.Management.Automation.PSScriptCmdlet.DoEndProcessing()
at System.Management.Automation.CommandProcessorBase.Complete()
At C:\tmp\FlexNet Manager Suite Installer 2019 R2\FlexNet Manager Suite Installer 2019 R2\FlexNet Manager
Suite\Support\ConfigHelper.ps1:1146 char:11
+ $ret = ExecuteCustomScripts $configMode $serverStep
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException
+ FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,ExecuteCustomScripts
0 Kudos
Highlighted
Rising star

Re: Issue while configuring inventory server

Jump to solution

Hi,

This migration process seems rather complex. I'd advice you to either raise a support ticket, or maybe get professional consulting support.

Best regards,

Markward

Softline Group is Europe's leading independent expert in Software Asset Management.
Highlighted
Occasional contributor

Re: Issue while configuring inventory server

Jump to solution

Hello Markward,

I moved the FNMS folder out of the other FNMS2019R2 folder and placed it directly in C:/tmp. Then the issue got resolved.

Thank you for the help.

Regards,

Nidhi Kamat

View solution in original post